Areca holding on to backup partition?

Help
Joe
2010-10-08
2012-10-08
  • Joe
    Joe
    2010-10-08

    I just finished the first backup (from the gui - running as root) of my root
    (/) and /home partitions (with some things like /proc and /media excluded). It
    worked great until my post-processing script tried to dismount the backup
    partition. The backup of home had successfully completed and then the root
    completed and the post-processing script kicked in to dismount the partition.
    I have the post scripts set up so that whoever finishes last dismounts the
    partition. I even dropped to command line and:

    bigbird@sananda:~/installs/areca$ sudo umount /media/linuxback
    sudo: cannot get working directory
    umount: /media/linuxback: device is busy.
    (In some cases useful info about processes that use
    the device is found by lsof(8) or fuser(1))
    bigbird@sananda:~/installs/areca$

    As soon as I exited the Areca gui, the dismount worked fine. Long ago, I had a
    similar problem with konqueror. If it had ever browsed a mount in the current
    session, then the only way to do a dismount that partition was to exit
    konqueror first, but that was also fixed long ago.

    Here's my setup:

    kubuntu karmic x86, Areca Backup Version 7.1.7 - May 19, 2010 downloaded from
    SF latest version yesterday.
    Running the gui as root.

    My log file is written to /media/dataspace /dev/sda8, a partition on my
    internal notebook drive. root is on /dev/sda6 and home is on sda9. (I know I
    have a lot of partitions. I'm thinking about simplifying my setup in the
    future.)

    My backup is on /dev/sda2 mounted on /media/linuxback - another partition on
    my internal notebook drive
    which is normally unmounted and requires root access to mount and access it
    (to keep my backups safer).
    The point is that nothing else uses this partition. There's nothing to keep it
    busy except Areca, when it's running.

    It is mounted by the pre-processing script I wrote and (should be) dismounted
    by one of my post-processing scripts.

    I verified that dolphin, my file browser, and konsole, my terminal app, were
    not accessing the mount when I tried to dismount it.
    If anything else was using the mount, the dismount would still not have worked
    after I exited Areca.

    Possibly related to this:

    I just checked the results. The root archive (the one that had the error in
    the post-processing script) appears to be fine I recovered/checked one file.
    The home archive, which completed with no errors, is completely empty except
    for a tiny history file that says the archive was deleted. I didn't delete it
    and areca didn't tell me it did either. I'm now rerunning just that backup,
    but it will be a couple of hours before it completes.

    If I can get this to work reliably, I'm going to put the backup scripts (from
    the wizard) in cron and let it run automatically from then on, occasionally
    copying the archive onto another external drive or to DVDs to guard against
    drive failure.

    A lot of backup programs are enterprise oriented and hard to configure. Areca
    is easy and does what I want it to do.
    I'd really like to use it if I can get it to work.

    I hope someone can help me with this.

    TIA

    Joe

    I can post log excerpts and my scripts or whatever will help.

     
  • Joe
    Joe
    2010-10-08

    It did it to me again!
    Here's the log entries:

    10-10-08 05:28 - INFO - Commit completed.
    10-10-08 05:28 - INFO - 9,219,727 kb read in 6,464 seconds.
    10-10-08 05:28 - INFO - Average data input : 1,426 kb/second.
    10-10-08 05:28 - INFO - 7,172,062 kb written in 6,464 seconds.
    10-10-08 05:28 - INFO - Average data output : 1,109 kb/second.
    10-10-08 05:28 - INFO - Checking archive (working directory : /media/linuxback/Backup/350722410/chk0) ...
    10-10-08 05:28 - INFO - Recovering from Unknown (Not dated) to Oct 8, 2010 3:40 AM.
    10-10-08 05:28 - INFO - Deleted entries won't be recovered.
    10-10-08 05:28 - INFO - Recovery filter : /
    10-10-08 05:28 - INFO - Adding /media/linuxback/Backup/350722410/home101008 (Full backup) to recovery list.
    10-10-08 05:28 - INFO - Previous archives will be ignored.
    10-10-08 05:28 - INFO - 1 archives will be processed.
    10-10-08 05:28 - INFO - Files will be recovered in /media/linuxback/Backup/350722410/chk0
    10-10-08 05:28 - INFO - Recovering in optimized mode.
    10-10-08 05:28 - INFO - 24869 files will be recovered.
    10-10-08 05:28 - INFO - Data recovery ...
    10-10-08 05:28 - INFO - Recovering /media/linuxback/Backup/350722410/home101008 (24869 files) ...
    10-10-08 05:39 - INFO - Processing archive 0 (/media/linuxback/Backup/350722410/chk0/lc/home101008) ...
    10-10-08 05:47 - INFO - Checking recovered files ...
    10-10-08 05:47 - INFO - Using content of archive /media/linuxback/Backup/350722410/home101008 as reference.
    10-10-08 05:47 - INFO - Recovery completed - Checking recovered files (this may take some time) ...
    10-10-08 05:48 - WARNING - bigbird/.kde/share/apps/okular/docdata/32928.SBY_Esoteric_Wisdom_Revealed
    .odt.xml has not been recovered ... it should have !
    10-10-08 05:48 - WARNING - bigbird/.openoffice.org/3/user/backup/SBY_Esoteric_Wisdom_Revealed
    .bak has not been recovered ... it should have !
    10-10-08 05:51 - INFO - Check completed - 24867 files successfully checked.
    10-10-08 05:51 - INFO - Deleting recovered files (/media/linuxback/Backup/350722410/chk0) ...
    10-10-08 05:52 - INFO - Recovered files deleted.
    10-10-08 05:52 - ERROR - The created archive (/media/linuxback/Backup/350722410/home101008) was not successfully checked. It will be deleted.
    10-10-08 05:52 - INFO - Deletion in progress ...
    10-10-08 05:52 - INFO - Starting deletion from Oct 8, 2010 3:40 AM.
    10-10-08 05:52 - INFO - home101008
    10-10-08 05:52 - INFO - Deletion completed - 1 archive deleted.
    10-10-08 05:52 - INFO - Deletion completed.
    10-10-08 05:52 - INFO - Validating and running processor : com.application.areca.processor.ShellScriptProcessor - /home/bigbird/areca/areca.home.post
    10-10-08 05:52 - INFO - Shell command [ "/home/bigbird/areca/areca.home.post"] executed - exit value = 1 : [umount: /media/linuxback: device is busy.]
    10-10-08 05:52 - ERROR - Error while executing Execute shell script (/home/bigbird/areca/areca.home.post) - com.application.areca.ApplicationException: Error running  "/home/bigbird/areca/areca.home.post" - exit value = 1 : [umount: /media/linuxback: device is busy.]
        at com.application.areca.processor.ShellScriptProcessor.runImpl(ShellScriptProcessor.java:116)
        at com.application.areca.processor.AbstractProcessor.run(AbstractProcessor.java:97)
        at com.application.areca.processor.ProcessorList.run(ProcessorList.java:82)
        at com.application.areca.AbstractTarget.processBackup(AbstractTarget.java:403)
        at com.application.areca.ActionProxy.processBackupOnTarget(ActionProxy.java:53)
        at com.application.areca.launcher.gui.Application$15.runCommand(Application.java:1180)
        at com.application.areca.launcher.gui.Application$ProcessRunner.run(Application.java:1662)
        at java.lang.Thread.run(Thread.java:636)
    
     
  • Joe
    Joe
    2010-10-08

    Posting it got me to reread it again.

    There were 2 files out of 24,869 that had some weird character encoding in
    them (probably garbage from an editing program crash) that Areca can't handle.
    I have deleted them and excluded the directories from the backup. I didn't
    even know they existed. If I had known, they would have been gone long ago.

    If at first you don't succeed ....

    But, it would be nice to have those files go into a quarantine area, etc. - at
    least if there are less than a threshold number of them - and let the rest of
    the backup succeed - at least as an option. They were only listed as a warning
    on the way in, but caused the whole backup to fail to verify.

    As far as the dismount problem, I have disabled the dismount code in my post
    scripts until that problem gets fixed.

    Off we go again for another try ....

    Joe

     
  • Joe
    Joe
    2010-10-08

    That fixed the backups themselves.

    Now, the only problem is not being able to dismount the partition in the post
    script.

     
  • Joe
    Joe
    2010-10-11

    The dismount problem really should be fixed, but since I'm going to run it
    from cron anyway, I'll just do the dismount in the cron script after Areca
    closes.