#10 Midi 3.2 Compile Errors

version 3.1
closed
nobody
5
2014-04-20
2012-05-09
Craig
No

Hi. I am using Midi in an Arduino environment. I have just updated the old MIDI2.6 library with the new Midi 3.2 version. This was done by replacing the "MIDI" folder in C:/arduino-1.0/libraries/MIDI with the identically named folder from the download. However I now get a number of compile errors from the library when compiling the sketch. These are included in the attachment. I tried also the 3.1 version of the library which gives similar results. If I replace the original 2.6 library, then all compiles without problems. Can you suggest what I am doing wrong. The new library contains some callbacks that I require, so using 2.6 is not an option.
Many thanks, Craig

Related

Bugs: #10

Discussion

  • Craig
    Craig
    2012-05-09

    Midi Error Log

     
    Attachments
  • Francois BEST
    Francois BEST
    2014-04-20

    Hello Craig,

    There is a new version of the library available, you can get it here:
    https://github.com/FortySevenEffects/arduino_midi_library/releases/tag/4.1

    Best regards,
    Francois.

     
    • Craig
      Craig
      2014-04-21

      Thanks,

      From: Francois BEST
      Sent: Sunday, April 20, 2014 11:18 PM
      To: [arduinomidilib:bugs]
      Subject: [arduinomidilib:bugs] #10 Midi 3.2 Compile Errors

      Hello Craig,

      There is a new version of the library available, you can get it here:
      https://github.com/FortySevenEffects/arduino_midi_library/releases/tag/4.1

      Best regards,
      Francois.


      [bugs:#10] Midi 3.2 Compile Errors

      Status: open
      Group: version 3.1
      Labels: Compatibility
      Created: Wed May 09, 2012 11:53 AM UTC by Craig
      Last Updated: Wed May 09, 2012 11:53 AM UTC
      Owner: nobody

      Hi. I am using Midi in an Arduino environment. I have just updated the old MIDI2.6 library with the new Midi 3.2 version. This was done by replacing the "MIDI" folder in C:/arduino-1.0/libraries/MIDI with the identically named folder from the download. However I now get a number of compile errors from the library when compiling the sketch. These are included in the attachment. I tried also the 3.1 version of the library which gives similar results. If I replace the original 2.6 library, then all compiles without problems. Can you suggest what I am doing wrong. The new library contains some callbacks that I require, so using 2.6 is not an option.
      Many thanks, Craig


      Sent from sourceforge.net because you indicated interest in https://sourceforge.net/p/arduinomidilib/bugs/10/

      To unsubscribe from further messages, please visit https://sourceforge.net/auth/subscriptions/

       

      Related

      Bugs: #10

      Attachments
  • Francois BEST
    Francois BEST
    2014-04-20

    • status: open --> closed