I need a bit of compiling help...

Help
2003-08-30
2003-08-30
  • Chris Devine
    Chris Devine
    2003-08-30

    I am trying to compile the latest stable aprsd on an older (redhat 2.2.14) small system, gcc version egcs-2.91.66 19990314/Linux (egcs-1.1.2 release), and I am having a problem. What do I need to upgrade to get aprsd to compile?

    Thanks for your time and work,
    Chris

    make[1]: Entering directory `/home/aprsd3/aprsd-2.2.5-14'                      
    Making all in src                                                              
    make[2]: Entering directory `/home/aprsd3/aprsd-2.2.5-14/src'                  
    source='aprsd.cpp' object='aprsd.o' libtool=no \                               
    depfile='.deps/aprsd.Po' tmpdepfile='.deps/aprsd.TPo' \                        
    depmode=gcc /bin/sh ../support/depcomp \                                       
    g++ -DHAVE_CONFIG_H -I. -I. -I.. -I../src    -g -O2 -Wall -pipe -pthread -c -o p
    aprsd.cpp: In function `int main(int, char **)':                               
    aprsd.cpp:954: parse error before string constant                              
    aprsd.cpp:992: `ostringstream' undeclared (first use this function)            
    aprsd.cpp:992: (Each undeclared identifier is reported only once               
    aprsd.cpp:992: for each function it appears in.)                               
    aprsd.cpp:992: parse error before `;'                                          
    aprsd.cpp:993: `osnetbc' undeclared (first use this function)                  
    aprsd.cpp:998: confused by earlier errors, bailing out                         
    make[2]: *** [aprsd.o] Error 1                                                 
    make[2]: Leaving directory `/home/aprsd3/aprsd-2.2.5-14/src'                   
    make[1]: *** [all-recursive] Error 1                                           
    make[1]: Leaving directory `/home/aprsd3/aprsd-2.2.5-14'                       
    make: *** [all] Error 2