#15 v 1.3.2 - Information not reported in log


This was my first run even with AppleJack. Used version
1.3.2 (and not 1.3.1 as shown in the scrolldown menu
that has not yet 1.3.2. I don't know if the following
is a bug, but I report it and would appreciate a
comment, if any: The following information lines
appeared while running 1.3.2 in SUM, but they did not
appear in AJ's log in Console:

[after disk repair and before Permissions repair]
/var/root/Library/Scripts/applejack.sh: Line 1: 144 Hangup
SystemStart Start Disks 2>&1 >/dev/null
Apr 24.04:42:50 com.apple.SecurityServer: Entering service

Is there any specific significance to that "Hangup"?
After entering SUM, I just typed applejack auto
restart, let the script do its job, without responding
to the interactive prompts that showed before each new
action. The whole process lasted ą 17 min., experienced
no problems.
Powerbook PowerBook G4 15" (AL) PowerPC G4 (1.1) -
CPU Speed: 1.33 GHz - RAM: 2 GB - Bus Speed: 167 MHz -
Boot ROM Version: 4.8.6f0


  • Logged In: YES

    Thank you for paying such close attention! That's very
    observant, and I appreciate you taking the time to notify
    me. However, I didn't design the log to be a full replica of
    ALL output to the screen. It's intended more as a
    step-by-step record of the runtime. Sometimes the system
    responds to AppleJack's commands with messages of it's own.
    The message above is of no concern, though I might consider
    adding that command's output to what gets captured in the log.