Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Cascading LOV problem

Help
2009-11-05
2013-04-22
  • Hello, I have a form with 2 select list. The second select list depends on first select list.  It worked on apex 3.1.1 na apexlib 1.6. I have upgraded to apex 3.2.1, then Cascading LOVS dont worked in all application in all workspaces. I have instaled and integrated apexlib 2.0, then cascading LOVs starts working except one workspace. If I try to debug page it write, that cascading lov is detected.  I have tried setup new application in 'bad' and cascading lovs have not worked. Then I have tried setup the same test application in other workspace and cascading lovs have  worked.
     
    Thanks for any sugestion how to resolve it.

     
  • Hi,

    please try again using Firefox with activated Firebug Plugin and check the Console Output. There should be a POST when Cascading Select List is refreshed.
    Maybe the Post is returning an error,

    Please check and tell me what error occurs,

    thanks,

    Peter

     
  • Hello,
    I have checked Console Output in Firebug, but No error apears. The post entry in console looks the same in "good" and "bad" workspace excepts the response.   But I have some new  . I have made new  test workspace assigned to the same schema as "BAD" workspace and new application with similar  page to test cascading LOVs.  It dont work.  Then I change schema in the new test worskpace an it works.
    There must be something bad in the schema, but what?

    JM.

     
  • Hi,

    you write that the POST-Response is different in good and bad case. Can you tell me what the Response is in not-working schema?

    Peter

     
  • The repsonse is:
    <select></select> 

    empty select list.

     
  • Well, in this case i think your problem is related to data. Try to execute the LOV Statement with the given values, does it return data?

    As for ApexLib i would say everything works, because the statement is executed, it just doesn't return any data.

    Please check data in working and non-working schemas.

    Peter

     
  • The data are the same.  The working schema has granted select on data from non working schema.   When I run LOVs select in  TOAD it  work uder non-working schema. 

     
  • Can you trace it and see which values are used to restrict your query?

    What is the content of the POST Request?

    Peter

     
  • Hm,

    can't see anything wrong at the moment, will take some time to investigate…

    Peter

     
  • I make a test with  "like"  in the  LOV select  in application in non-working schema. When I  use  contidion  VP=:P1_VP it returns empty list ,
    when use condititino VP like  :P1_VP||'%' it returns all records in table. So the value coming from parent LOV is empty.