Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

error when trying to use Apexlib on Apex 4.0

Help
Anonymous
2010-09-30
2013-04-22

  • Anonymous
    2010-09-30

    I've upgraded Apexlib on my apex.oracle.com workspace (I've installed Apexlib v2_1_3).
    I've also upgraded Apex builder plugin in IE and FF (now I use ApexBuilderPlugin_v2_0_1).
    But when I try to use ApexLib on a field of my application I get errors.
    For example if I choose the "Date Picker, dare only" option of ApexLib widget, I get these errors:

    "Field ID F4000_P4311_CSIZE doesn't exist!"

    "Field ID F4000_P4311_CMAXLENGTH doesn't exist!"

    Also the other option raise similar errors (e.g. option "Label left, no help…" raise "Field ID F4000_P4311_CMAXLENGTH doesn't exist!" error)

    How can I solve?

     

  • Anonymous
    2010-09-30

    Sorry…
    The option "Label left, no help…" raise "Field ID F4000_P4311_LABEL_ALIGNMENT doesn't exist!" error and not "Field ID F4000_P4311_CMAXLENGTH doesn't exist!"  error.

     
  • Hi,

    which version of APEX do you use? Which version of ApexLib did you use before you upgraded to 2.1.3?

    Where do you get these errors? In Application Builder or at runtime?

    Peter

     

  • Anonymous
    2010-10-04

    I use APEX 4.0.1.00.03, which is the actual version installed on apex.oracle.com demo workspace.
    I get these errors in Application Builder.
    Before upgrading to Apexlib 2.1.3 I used Apexlib v1.6upd.
    I've deleted all v.1.6upd database objects and I've reinstalled ApexLib object using ApexLib_Install_for_apex_oracle.sql script. I've also loaded in static file directory new apexlib  javascript and css file (ApexLib_Full-min.js and ApexLib.css).
    Then I've updated my application model with calls to: ApexLib_Full-min.js e ApexLib.css (I've removed obsolete calls to ApexLib_Lov.js and jquery_Compressed.js).
    I followes integration instructions mentioned here: http://apexlib.oracleapex.info/#integrate.

     

     

  • Anonymous
    2010-10-04

    Other useful information:
    I get the same error on IE 7 and FF 3.6.

     
  • Ok,

    so this might come from ApexLib Builder Plugin.

    Which Builder Plugin config files do you use? -> open the BuilderPlugin config screen (greasemonkey -> builderplugin -> config) and check the path.

    Either use a local path with the latest config files, or point it to http://apexlib.oracleapex.info/v2.1/BuilderPlugin/

    brgds,

    Peter

     

  • Anonymous
    2010-10-04

    I use http://builderplugin.oracleapex.info/config/2.0/ as config path for builder plugin (which is the default orginal path setted in apex_builder_plugin_for_FF.user.js script included in ApexBuilderPlugin_v2_0_1.zip that I downloaded).

     
  • Well yes, you are right.  Your path should work.

    On which Page do you geht this error?

    Did you try a Ctrl+F5 to reload the page and all used js-files?

     
  • What kind of item do you look at in page 4311 ?

     

  • Anonymous
    2010-10-05

    I tryed to reload page many times and I tryed to clean also browser cache, but the problem is still there.
    Sorry I didn't understand your question "What kind of item do you look at in page 4311 ?". If you mean page item, I tryed with a date field with option "Date Picker, date only" and also with a text filed "Label left, no help and add column".
    The behaviour of Builder Plugin in page 4311 is the following:
    I can see the Plugin LOV with 3 option: "Date Picker, date only", "Money, right alignment" and "Label left, no help and add column". When I try to select one of the option I get the errors than I described before in an alert box. Then, when I click the OK button of the alert box, the area where it sould appear the "Display As" select list bliks.

     
  • Sorry, still can't reproduce this behaviour, for me it works fine with all different item types.

    Did you create own config files or set operations?

    Can you send me a screenshot of the error message or can i get access to your application to try it?

    Please mail me to: apexlib@oracleapex.info

    Peter

     

  • Anonymous
    2010-10-05

    I send you a message with reference to access my application.
    Could be something related to different jquery version used by Apexlib and ApexBuilderPlugin?
    In my application I 've integrated last version of ApexLib_Full-min.js which uses  JQuery v1.3.2, but ApexBuilderPlugin_v2_0_1 uses  jQuery 1.2.1. Could it raise error when ApexBuilderPlugin try to select a page field?