Popup LOV not working

Help
RenedeH
2007-11-13
2013-04-22
  • RenedeH
    RenedeH
    2007-11-13

    Hi Patrick,

    We want to use the 'Popup Key LOV (Displays description, returns key value)' item, but in IE it doesn't work (while it does in FF).

    The error it gives is: 'Can't move focus to the control because it is invisible, not enabled, or of a type that does not accept the focus.'

    When I turn on debugging in IE the first part of the script reads 'if(!window.apexlib)' so I guess it might have to do something with the ApexLib.

    Can you look into this please?

    Regards,

    René

     
    • Patrick Wolf
      Patrick Wolf
      2007-11-13

      Hi René,

      yes that's a known problem for some time. See bug# 1677470. Actually I thought about that problem some days ago and finally had an idea how to solve it without too many code changes. I'm currently at Oracle Open World, but as soon as I'm home I should be able to send you a fix for that. Update the thread if I do forget.

      As a workaround:

      Comment out the

      ApexLib_Browser.setLovIconsNonNavigable;

      call in page 0 Region "ApexLib - Before footer".

      Patrick

       
    • RenedeH
      RenedeH
      2007-11-23

      Hi Patrick,

      Sorry for not looking at the known bugs before posting.

      The work around is working very well. Has it any impact on other LOV's?

      Regards,

      René

       
      • Patrick Wolf
        Patrick Wolf
        2007-11-23

        The impact is that the LOV icon is navigable again for all LOVs. That's the only impact.

        Patrick