Hi Gretchen -
 
I'm currently away from work, but I can at least (for now) guess at a possible solution.
 
If I remember correctly, when APBS installs via RPM it creates a /usr/local/apbs-*/ directory where it places the binary (and tools/examples directories if you've installed them), as well as placing the necessary libraries in /usr/local/lib and documentation in /usr/share.  The binary is then most likely (I think) symbolically linked to /usr/bin or /usr/local/bin/i686*/, so you may want to make sure that if either of these are present they are deleted as well.
 
This will hopefully fix things - if not, please send me the complete error messages and I'll try to take a look as soon as possible.
 
Todd
 
 
On 12/23/05, Gretchen Meinke <meinke@bbri.org> wrote:
Hello.

I am getting "conflict error" when i try to install the apbs 4.0 rpm
platform: redhat 9.0
I had installed apbs 3.2.1 previously.

the results from

rpm -i apbs-0.4.0-1.i386.rpm

are a number of lines like:
file /usr/local/bin/i686-pc-linux/apbs from install of apbs-0.4.0-1
conflicts with file from package apbs-0.3.2-1

I have since removed via rpm three apbs packages:

rpm -e apbs-0.3.2-1.i386.rpm
rpm -e apbs-tools-0.3.2-1.i386.rpm
rpm -e apbs-examples-0.3.2-1.i386.rpm

(I am still running maloc-0.1-2.i386.rpm )

I then removed the one of the offending directories, but no avail:

rm -r /usr/local/lib/apbs

what to do next?

thanks in advance.
Gretchen Meinke



-------------------------------------------------------
This SF.net email is sponsored by: Splunk Inc. Do you grep through log files
for problems?  Stop!  Download the new AJAX search engine that makes
searching your log files as easy as surfing the  web.  DOWNLOAD SPLUNK!
http://ads.osdn.com/?ad_id=7637&alloc_id=16865&op=click
_______________________________________________
apbs-users mailing list
apbs-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/apbs-users