I tried as well with the new version 1.4 but still get the same message.
I installed first the binary APBS-1.4-linux-x86_64 (which btw doesn't have anymore
I compiled and installed also the source version APBS-1.4-source. Still the same message.
Have I downloaded the wrong files?
So at the moment, I set the
--gmemceil=2000 of which corresponds to the limit ~2G RAM for 32 build. Then I got the input file which suggests mg-para calculations with pdime 4 4 4. Does this mean I need to run apbs 4*4*4=64 times with async from 0:63 and then to merge it afterwards with mergedx2?
Do you have another solution?
With many thanks,

From: Baker, Nathan []
Sent: Saturday, August 04, 2012 2:55 AM
To: Monson, Kyle E; Vulovic, M.V. (MCB);
Subject: RE: maximum memory limit inputgen



We have a 64-bit build for APBS 1.4.  Have you tried that?




Nathan Baker
Pacific Northwest National Laboratory
Tel:  +1-509-375-3997


From: Monson, Kyle E
Sent: Friday, August 03, 2012 9:35 AM
To: Baker, Nathan;;
Subject: RE: maximum memory limit inputgen


This can only be overcome with a 64-bit build of APBS. A 32-bit executable can only have a heap of about 2GB as you have seen.


Im not sure what our plans are for a 64-bit build.


From: Baker, Nathan
Sent: August 03, 2012 06:32
Subject: Re: [apbs-users] maximum memory limit inputgen




Do you have the same problem with the new APBS 1.4?




Nathan Baker
Pacific Northwest National Laboratory
Tel:  +1-509-375-3997


From: []
Sent: Friday, August 03, 2012 5:54 AM
Subject: [apbs-users] maximum memory limit inputgen


Dear all,

I was trying to upped the maximum allowable memory used by APBS. I would like to calculate the potential distribution for a larger Hemoglobin molecule. Machine on which I am running the program has 256GB RAM memory. 

Unfortunately, I always get the same message:


Unable to allocate memory!

(This often means you don't have enough memory available for this calculation.) FATAL ERROR: Unable to allocate enough memory for problem size.

FATAL ERROR: You requested 2203582984 bytes of RAM.

FATAL ERROR: Check that your system has that much memory.

VASSERT: ASSERTION FAILURE!  filename vmem.c, line 252, (ram != ((void *)0))



This corresponds to 'only' ~2GB RAM. Could you help me to overcome this limitation?


I first call that should allow me to define the maximum memory :~ python ~/soft/apbs-1.3-amd64/share/tools/manip/ --gmemceil=100000 Hb.pqr


And then as a second step I run apbs program on a newly generated  file ~/soft/apbs-1.3-amd64/bin/apbs

And this still gives me the same error message above.

Do you know what could be the problem? Am I doing something wrong?

thanks a lot


Leiden University Medical Center
Department of Molecular Cell Biology
Section Electron Microscopy
Postal Zone S1-P
P.O.Box 9600
2300 RC Leiden
The Netherlands
Visiting address: Einthovenweg 20
2333 ZC Leiden
Tel:  (+31) 71 526 9265
Fax: (+31) 71 526 8270