Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

FYI: Nokia E51 working!

Help
Anonymous
2010-02-14
2012-12-10

  • Anonymous
    2010-02-14

    Great tool! I have it running on KUbuntu 9.10, with the packages from the repository (64 bit) in combination with my Nokia E51. Tested Kaffein, file manager and last and most important Open Office Impress!

     
  • Did you do something specific, apart from the defaults?
    I just tried with my Nokia E51 and I got the client installed fine, but it can not connect.
    Which device did you choose for the connection? I'm trying comm:bt* (0, 1, …) and I get a java.io.IOException error=-1

    For reference: another person that has what seems to be the same problem is at https://sourceforge.net/projects/anyremote/forums/forum/552292/topic/3362871

    I did execute hciconfig hci0 piscan as said in the documentation.

     
  • Mike
    Mike
    2010-02-22

    Have You run search ?
    After the search You should have "anyRemote" in the list along with that comm:XX

     
  • Thanks, that makes sense. However I don't see any such device.

    I've tried again: first I start gAnyRemote, then I click on "Start" to start the server.
    In the phone I use "Clean address" to remove all the devices.
    Then do "Search": the phone says "Found 1", then "Retrieving services 0 …", and after a while I get a long list with "comm:USB0", "comm:COM0", "comm:IR0", "comm:BT0" … "comm:BT63". That's all.
    I then click on "Exit" on the phone. When I start anyRemote again, the list is empty. If I search again, I get the same list of devices as before.

     
  • This seems to be a known problem: http://anyremote.sourceforge.net/faq.html#faq16

    I've tried to reinstall the JAR file, the default 16x16 version (anyRemote-16.jar, version 4.19(0)). When it asks whether it should save the existing application data I answer "no".
    After that I get the same results as before.

    I've installed the 32x32 version, and answered this time "yes" to save the existing application data. Again same result.

    Tried again, installing the 64x64 version. This is called "anyRemote-64b.jar": at this point I remembered having read that the "*b.jar" version should be used for Nokia phones, but the PC application did not let me choose any "*b" version when uploading. Reading that page again more carefully it's clear that I should have chosen the 64x64 version from the beginning.
    Anyway, although the application now looks better with the bigger icons, I get the same result: there is no anyRemote device, and if I try comm:bt1 I get the screen with the nine locks on it and three more that are mostly outside the screen. I guess the error message just gets pushed out of the screen by the bigger icons, since it appeared below the locks with the 16x16 and 32x32 version.

     
  • Mike
    Mike
    2010-02-23

    >However I don't see any such device.
    >I've tried again: first I start gAnyRemote, then I click on "Start" to start the server.
    >Then do "Search": the phone says "Found 1", then "Retrieving services 0 …"
    Seems this is the problem. Since no anyRemote server was found, then there is no peer to connect.

    Try to run "sdptool browse local"
    I have:
    sdptool browse local
    Browsing FF:FF:FF:00:00:00 …
    anyremote@anyremote:~$ sdptool browse local
    Browsing FF:FF:FF:00:00:00 …
    Service Name: anyRemote
    Service Description: Bluetooth remote control
    Service Provider: anyRemote
    Service RecHandle: 0x10000
    Service Class ID List:
      "Serial Port" (0x1101)
    Protocol Descriptor List:
      "L2CAP" (0x0100)
      "RFCOMM" (0x0003)
        Channel: 19
    Profile Descriptor List:
      "Serial Port" (0x1101)
        Version: 0x0100

     
  • I don't get any such device. I tried this before starting gAnyRemote (Ubuntu 9.10, updated, standard gAnyRemote package from the official repository) and after starting it and clicking the "Start" button which I guess starts the anyRemote server.

    Starting anyRemote from the console however makes it appear:
    anyremote -f /usr/share/anyremote/cfg-data/Server-mode/evince.cfg

    This way it works perfectly.
    Now, after doing that, I stopped it with control-c and tried again with gAnyRemote and it does work. I see the device anyRemote and everything works as expected.

    I've tried to stop it, restart gAnyRemote (not just stop the server, but quit the application and start it again), clear the connection, and search again, and it works again perfectly.

    Thank you very much.

     
  • Rahul Jonwal
    Rahul Jonwal
    2010-02-26

    its not working with LG Dynamite kg300 , its not searching any server.

     
  • Mike
    Mike
    2010-02-27

    2 matmota:
    By the way, what was the source of You problem ?

    2 jhony007:
    does kg300 supports jsr82 ?
    what shows command sdptool browse local ?