Mac os x 10.4.2

Help
2005-10-10
2013-04-15
  • stefanosenni
    stefanosenni
    2005-10-10

    Hi,
    i have installed the installer for Tiger but when i launch Ants the console says:

    [JavaAppLauncher Warning] Specifying a specific version for JVMVersion 1.3.1 is deprecated.  Use the more general 1.3* instead.
    Unable to locate the application's 'main' class. The class 'ants.p2p.gui.FrameAnt' must be public and have a 'public static void main(String[])' method. (LAX)
    Unable to Launch Java Application: Unable to locate the application's 'main' class. The class 'ants.p2p.gui.FrameAnt' must be public and have a 'public static void main(String[])' method. (LAX)

    if i open the terminal and i say:

    /System/Library/Frameworks/JavaVM.framework/Versions/1.5/Commands/java -version

    the result is:

    Java version "1.5.0_02"
    Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_02-56)
    Java HotSpot(TM) Client VM (build 1.5.0_02-36, mixed mode, sharing)

    I don't understand where is it the problem?

    Thanx

     
    • H0le Pr1vacy
      H0le Pr1vacy
      2005-10-19

      Don't use Java 5.0 update 2, but *AT LEAST* update 4. If you use latest version is better.

      Before installing a new version, uninstall ALL previous Java versions!