Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Anybody working on Juno support?

ToolUsr
2012-07-02
2013-05-28
  • ToolUsr
    ToolUsr
    2012-07-02

    The package presently can't be used with Juno unfortunately and needs an update.

     
  • I am also trying to install it on Juno and I am getting the following dependency error:

    Cannot complete the install because one or more required items could not be found.
      Missing requirement: ANTLR IDE- GUnit Tools 1.1.0.201108281759 (org.deved.antlride.feature.gunit.feature.group 1.1.0.201108281759) requires 'org.eclipse.dltk.core [3.0.0,4.0.0)' but it could not be found

    Knowing that I have previously installed all the necessary dependencies:

    Installed Juno deps:
      Dynamic Languages Toolkit - Core Frameworks 4.0.0.201206120848 org.eclipse.dltk.core.feature.group Eclipse.org
      Graphical Editing Framework GEF 3.8.0.201206112118 org.eclipse.gef.feature.group Eclipse.org
      Graphical Editing Framework Zest Visualization Toolkit 1.4.0.201206112118 org.eclipse.zest.feature.group Eclipse.org

    Anyone know how to or when this issue is going to be resolved?

    Best regards,
    Sebastian

     
  • Jan Krabbenbos
    Jan Krabbenbos
    2012-08-04

    I have the same issue. After some tries and fiddling around to get my Eclipse environment up to date I decided to download the zip file and add it to the Eclipse directory. This seems to work, more or less. I could not change my project to an ANTLR project, as the menu entry was only visible until I clicked on it. But the *.g file gets the icon of ANTLR and when opening Eclipse asked to change the project to an ANTLR project (I'm not sure of the sequence of working, as I did some trial and error here). Now it works as a ANTLR project.

    I guess the IDE does work, but for installing it, it needs the boundary of some versions to be greater. The '' part should be adapted for the required packages. I have looked at the sources, but have not been able yet to find where this is defined.

    Regards,
    Jan

     
  • John Haley
    John Haley
    2012-08-10

    I've been able to get this to work with Juno.  Use the following steps at your own discretion.

    1. shut down eclipse
    2. You need to copy org.eclipse.dltk.* version 3.0.x plugins from an earlier eclipse install.  Specifically, I used:
    org.eclipse.dltk.console (3.0.0.v20101211-0412) "Dynamic Languages Toolkit Console Core"
    org.eclipse.dltk.console.ui (3.0.0.v20101212-1106) "Dynamic Languages Toolkit Console UI"
    org.eclipse.dltk.core (3.0.1.v20110823) "Dynamic Languages Toolkit Core"
    org.eclipse.dltk.core.manipulation (3.0.0.v20110609-1525) "pluginName"
    org.eclipse.dltk.debug (3.0.1.v20110824) "Dynamic Languages Toolkit Debug Core"
    org.eclipse.dltk.debug.ui (3.0.0.v20110423) "Dynamic Languages Toolkit Debug UI"
    org.eclipse.dltk.formatter (3.0.0.v20110609-1525) "Dynamic Languages Toolkit Formatter"
    org.eclipse.dltk.launching (3.0.0.v20110423) "Dynamic Languages Toolkit Launching Core"
    org.eclipse.dltk.ui (3.0.1.v20110823) "Dynamic Languages Toolkit Core UI"
    3. Start eclipse and perform the install.  There should be no dependency problems.

     
  • Are their any plans to get  ANTLR-IDE running out-of-the-box for Juno?

    best regards,
    tony

     
  • I installed ANTLR IDE from the Eclipse Marketplace under Juno and it has been working just fine. I didn't have to do anything for it to work. Has it been updated or am I just lucky that I somehow already had the needed dependencies installed?

     
  • Keith Paterson
    Keith Paterson
    2012-08-21

    I installed, too using the Marketplace. Everything seems to be working fine.

     
  • Well I have just freshlly installed Eclipse Classic 4.2 and I still cant install it from the Marletplace. I am getting these error:

    Cannot complete the install because one or more required items could not be found.
      Software being installed: ANTLR IDE- JDT Integration (optional) 2.1.2.201108281759 (org.deved.antlride.feature.integration.jdt.feature.group 2.1.2.201108281759)
      Missing requirement: ANTLR IDE- JDT Integration (optional) 2.1.2.201108281759 (org.deved.antlride.feature.integration.jdt.feature.group 2.1.2.201108281759) requires 'org.eclipse.dltk.core [3.0.0,4.0.0)' but it could not be found

     
  • Jan Krabbenbos
    Jan Krabbenbos
    2012-09-04

    I have downloaded the core dltk 3.0.0 files from http://download.eclipse.org/technology/dltk/downloads/drops/R3.0/S-3.0.1-201108261011/ and installed them in the Eclipse Juno directory. Just as natterco described, but without selecting the files, just copying the features and plugin directories. And it works.

    Further I have added a bug report. Seems appropriate for this issue to get more attention.