Announcement For Anyone Running Gtk < 2.6

Justin
2007-04-26
2013-04-22
  • Justin
    Justin
    2007-04-26

    Greetings!

    It is with a heavy heart that I have to declare AMA officially unsupported on any GTK platform that is less than version 2.6.

    While trying to track down bugs in the centOS distribution before version 5.0 (the latest version), meaning 4.2, 4.3 etc, I have found that there are actual widgets in use that exist only in version 2.6 and above in GTK.

    I'm not going to recode 2/3rds of the application so that people can run the app on older distributions. All major up-to-date versions of distros have the libraries necessary to run AMA.
    This includes:

    fedora 5 + 
    Ubuntu 6.10 +
    Debian 3.1 +
    Red Hat Enterprise Linux 5 (earlier versions may work)
    CentOS 5 +

    I personally tested CentOS 5 today (before testing earlier versions) and ama compiled just fine.

    If you need AMA and absolutely can not upgrade, you can download gtk and compile it in a non-standard directory (such as /usr/local/) and link to them. I am willing to help (within reason) anyone who needs help compiling gtk and ama against a custom compile.

    Everyone else who needs ama, I urge you to upgrade to a more recent version of your chosen distribution.