Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Mismatch between the program and library buil

Help
TIM
2011-02-01
2012-12-07
  • TIM
    TIM
    2011-02-01

    ~/Downloads/AMDOverdriveCtrl % AMDOverdriveCtrl
    Fatal Error: Mismatch between the program and library build versions detected.
    The library used 2.8 (no debug,Unicode,compiler with C++ ABI 1002,wx containers,compatible with 2.4,compatible with 2.6),
    and your program used 2.8 (no debug,Unicode,compiler with C++ ABI 1002,wx containers,compatible with 2.6).
    zsh: abort      AMDOverdriveCtrl

    on Fedora 14/x64
    can you help me with that please ?

     
  • Hi,

    the program was developed on Ubuntu 10.10 amd64. To be honest, I don't have any experience with Fedora. There is obviously some kind of difference in the wxWidgets packages, but I don't know, what it could be.

    I think the best would be, if you get the sources and compile the program on your Fedora box. You will need the AMD ADL SDK, a basic build environment and the wxWidgets dev packages. You can find some links and instructions on the download page (readme.txt).

    This is probably not the answer you wanted to hear, but I really don't know what the problem is. Sorry.

    regards
    tgiling

     
  • TIM
    TIM
    2011-04-13

    I did same problem

    /Downloads/AMDOverdriveCtrl % make
    g++ -mwindows -s -pthread   -lwx_gtk2u_richtext-2.8 -lwx_gtk2u_aui-2.8 -lwx_gtk2u_xrc-2.8 -lwx_gtk2u_qa-2.8 -lwx_gtk2u_html-2.8 -lwx_gtk2u_adv-2.8 -lwx_gtk2u_core-2.8 -lwx_baseu_xml-2.8 -lwx_baseu_net-2.8 -lwx_baseu-2.8  -ldl -o./Release/AMDOverdriveCtrl ./src/CFanSpeedPanel.o ./src/COvdrSettingsPanel.o ./src/CFanControlPanel.o ./src/CColorTempPanel.o ./src/BezierMath.o ./src/Color.o ./src/CSettingsPanel.o ./src/adl.o ./src/CAuthorPanel.o ./src/CAppProfilePanel.o ./src/main.o ./src/gui.o ./src/CTaskBarIcon.o ./src/CMonitorPanel.o ./src/CInfoPanel.o -o Release/AMDOverdriveCtrl
    ...
    build completed.
    ...
    
    /Downloads/AMDOverdriveCtrl % AMDOverdriveCtrl 
    Fatal Error: Mismatch between the program and library build versions detected.
    The library used 2.8 (no debug,Unicode,compiler with C++ ABI 1002,wx containers,compatible with 2.4,compatible with 2.6),
    and your program used 2.8 (no debug,Unicode,compiler with C++ ABI 1002,wx containers,compatible with 2.6).
    zsh: abort      AMDOverdriveCtrl
    
     
  • TIM
    TIM
    2011-05-06

    what is the output of your command ?

    # wx-config -debug=no -libs -unicode=yes

    -pthread   -lwx_gtk2u_richtext-2.8 -lwx_gtk2u_aui-2.8 -lwx_gtk2u_xrc-2.8 -lwx_gtk2u_qa-2.8 -lwx_gtk2u_html-2.8 -lwx_gtk2u_adv-2.8 -lwx_gtk2u_core-2.8 -lwx_baseu_xml-2.8 -lwx_baseu_net-2.8 -lwx_baseu-2.8