Hi Alina,

Thanks for your reply. I've added the list to cc so others are updated too and can keep up with the discussion

2011/7/10 Alina Weber <weber-alina@hotmail.de>
Hi Frans,


Yes I installed it on 64 Bit, knowing that it is 32 Bit only.

For me it was more important to get it working on 64Bit with Bugs, than using it on 32 Bit, because I downloaded 64Bit and had not enough blank discs. Thinking about the things you write I am know wondering why I throughout was able to install it?
But I will test it on a 32Bit version in a few days, to see which problems occur only on 64Bit.

I do my testing on virtual machines (using virtualbox). That has the additional advantage that you can install from an iso file, so no need to burn a disc. I seem to recall it is also possible to install from usb.
If you want to I can also create a 64 bit test version for you, or provide instructions on how to build it yourself.


relating to your other remarks:
The only thing I know is, that the Control file is used by the Package Manager to build dependecies. I am not sure but I remember that the Packages file is based on this information? Also not sure if I really had to change it, but I will try it out.


What do you mean with "this did not trigger a problem"? That it is no problem to remove this dependencies or that this should not have been a problem? (I am no native speaker, so I don't understand everything) I had to do this because this Packages can`t be installed, maybe because there are no Packages for Ubuntu 11.04 with this name ;) Otherwise hdactl can't be installed because it has "broken dependencies"
Well I'm not a native speaker either (we're neighbours, country-wise).  What I wanted to say is:
I've removed the dependencies on rdoc, irb and libracc-runtime-ruby, rebuild the package and did a clean install on both 10.04 and 11.04 and did not encounter any obvious issues (I've installed a package or two to test things, but did not do in-depth testing.

Same thing with libc6. Here I am 100% sure, that I had to do this. Maybe the Package Manager thinks that 2.12 is older than 2.4? Don't know, but for me it was a problem.
Hm, I didn't encounter this. Can you retest with the packages I've uploaded to amahi.99k.org (they are all in the repo.tar.gz file)


As I said, I will the things it out in a few days.  
kind regards,
Alina
Cool. Thanks alot for your help and mails.
Frans
 

Date: Sun, 10 Jul 2011 10:47:50 +0200
Subject: Re: [Amahi-devel] Amahi on Ubuntu 11.04
From: fransmeulenbroeks@gmail.com
To: weber-alina@hotmail.de
CC: amahi-devel@lists.sourceforge.net


Hi Alina, all,

I looked at your changes in the wiki page.

A few remarks, your text is below, my remarks start with FM:

-----------------------

FM: Not 100% sure but I think the cotnrol file does not need changing, This info is used to build the Packages file
after Package: hdactl:
change Architecture to "all"

FM: were you installing for 64 bit? Changing this from any to all is no good. There are a few hardware specific files in the package (at least hdactl-hup)

replace:
"irb" with "irb | ruby"
"libracc-runtime-ruby" with "libracc-runtime-ruby | libruby"
"rdoc" with "rdoc | libruby"

FM: I remvoed these dependencies completely; this did not trigger a problem

"libc6 (>=2.4)" with "libc6 (>=2.4) | libc6"

FM: no idea why you are doing this; you mention 2.12 in your email but 2.12 is > 2.4 so this should not be a problem. I did not change this and did not run into problems (note that this is automatically generated)

change "i386" under filename to "all"

FM: this is no good, the package has 386 code in it.

Insert your new Size and MD5sum
and save the file
-------------------------------

I've updated my test image.
If you want to feel free to test it.
Just do a
wget http://amahi.99k.org/debian.install
then do a
sh debian.install <your-install-code-goes-here>

Please report back the results (and feel free to ping me (eFfeM) on irc).
Note again that this is 386 only.

Enjoy, Frans