Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#251 Module intel8x0m doesn't work corectly on Intel 82801

open
nobody
None
5
2005-11-07
2005-11-07
Jeremy2nd
No

I have a laptop ASUS M6858NE, Gentoo Linux kernel
2.6.13-r5 and chipset:
0000:00:1f.5 Multimedia audio controller: Intel Corp.
82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio
Controller (rev 03)
0000:00:1f.6 Modem: Intel Corp. 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) AC'97 Modem Controller (rev 03)

As I have found out, the module snd-intel8x0m should
support this chipset. Nevertheless, when I load this
module, these messages are issued:

ACPI: PCI Interrupt 0000:00:1f.6[B] -> Link [LNKB] ->
GSI 4 (level, low) -> IRQ 4
PCI: Setting latency timer of device 0000:00:1f.6 to 64
ALSA sound/pci/ac97/ac97_codec.c:2017: MC'97 1
converters and GPIO not ready (0xff00)

I think, this issue could be the cause of my troubles
with modem (see
http://forums.gentoo.org/viewtopic-t-366796-highlight-.html\).
When I try to use a modem (using slmodem driver), the
following messages are issued:

ALSA sound/pci/intel8x0m.c:401: codec_semaphore:
semaphore is not ready [0x1][0x700300]
ALSA sound/pci/intel8x0m.c:415: codec_write 1:
semaphore is not ready for register 0x54

My sound system based on snd-intel8x0 works fine.

Can I do something with it or I just have to wait for
change in the snd-intel8x0m module?

Thanks for any help in advance.

Discussion