Hi,
I am a novice linux user. I have a Dell Inspiron 1705. It has a Intel 945 board with Sigmatel codec (STAC9200 as reported by alsa). I run Debian Unstable in my laptop. I installed alsa-1.0.10-3. But it gives silence output. I downloaded the latest alsa current release ( 1.0.11rc4) and tried to compile it.

Configure options used,
$ ./configure --with-debug=full --with-kernel=/usr/src/linux-headers-2.6.16-1-686-smp/ --with-cards=all -with-oss=yes
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking for ranlib... ranlib
.
.
config.status: include/version.h is unchanged
config.status: creating include/autoconf- extra.h
config.status: include/autoconf-extra.h is unchanged
Hacking autoconf.h...

$ make
.
.
make -C /usr/src/linux-headers-2.6.16-1-686-smp/ SUBDIRS=/root/alsa-driver-1.0.11rc4  modules
make[1]: Entering directory `/usr/src/linux- headers-2.6.16-1-686-smp'
  Building modules, stage 2.
  MODPOST
make[1]: Leaving directory `/usr/src/linux-headers-2.6.16-1-686-smp'
utils/link-modules /root/alsa-driver-1.0.11rc4

ALSA modules were successfully compiled.

It reports that modules are compiled succesfully. But make install fails

$ make install
find /lib/modules/2.6.16-1-686-smp/kernel/sound -name 'snd*.*o' | xargs rm -f
make[1]: Entering directory `/root/alsa- driver-1.0.11rc4/acore'
mkdir -p /lib/modules/2.6.16-1-686-smp/kernel/sound/acore
cp snd-hwdep.ko snd-page-alloc.ko snd-pcm.ko snd-rawmidi.ko snd-rtctimer.ko snd-timer.ko snd.ko /lib/modules/2.6.16-1-686-smp/kernel/sound/acore
cp: cannot stat `snd-hwdep.ko': No such file or directory
cp: cannot stat `snd-page-alloc.ko': No such file or directory
cp: cannot stat `snd-pcm.ko': No such file or directory
cp: cannot stat `snd-rawmidi.ko ': No such file or directory
cp: cannot stat `snd-rtctimer.ko': No such file or directory
cp: cannot stat `snd-timer.ko': No such file or directory
cp: cannot stat `snd.ko': No such file or directory
make[1]: *** [modules_install] Error 1
make[1]: Leaving directory `/root/alsa-driver-1.0.11rc4/acore'
make: *** [install-modules] Error 1


The soundcar id listed as unknown device by lspci

0000:00:1b.0 0403: Intel Corp.: Unknown device 27d8 (rev 01)

Can anyone give me hints to get my audio working.

Thanks in advance
Damodharan