Hello,

    I am desesperated with soundcard and alsa configuration that i think that it freezes my system.
    I got a lots of problems with my sound-system and maybe a wrong alsa configuration?

    My system is: $ cat /proc/asound/card0/codec#* | grep Codec
    Codec: Realtek ALC887

    $aplay -l
    **** List of PLAYBACK Hardware Devices ****
    card 0: Intel [HDA Intel], device 0: ALC887 Analog [ALC887 Analog]
    Subdevices: 0/1
    Subdevice #0: subdevice #0
    card 0: Intel [HDA Intel], device 1: ALC887 Digital [ALC887 Digital]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
    Subdevices: 1/1

    the bootlog always shows:
    hda-intel: IRQ timing workaround is activated for card #1. Suggest a bigger bdl_pos_adj.

    and after a minutes ... i got freeze system and log shows a lots of:

    [ 6684.079702] ALSA sound/pci/hda/hda_intel.c:819: send_cmd timeout: IRS=0xffff, val=0x470d80
    [ 6684.079775] ALSA sound/pci/hda/hda_intel.c:819: send_cmd timeout: IRS=0xffff, val=0x470e02
    [ 6684.079850] ALSA sound/pci/hda/hda_intel.c:819: send_cmd timeout: IRS=0xffff, val=0x470d81
    [ 6684.080045] ALSA sound/pci/hda/hda_intel.c:819: send_cmd timeout: IRS=0xffff, val=0x4f2d00
    [ 6684.080117] ALSA sound/pci/hda/hda_intel.c:819: send_cmd timeout: IRS=0xffff, val=0x472d01
    [ 6684.080189] ALSA sound/pci/hda/hda_intel.c:819: send_cmd timeout: IRS=0xffff, val=0x5f0700
    [ 6684.080192] hda-codec: out of range cmd 0:0:5:707:fffffffc
    [ 6684.080385] ALSA sound/pci/hda/hda_intel.c:819: send_cmd timeout: IRS=0xffff, val=0x4f2d00
    [ 6684.080457] ALSA sound/pci/hda/hda_intel.c:819: send_cmd timeout: IRS=0xffff, val=0x472d01
    [ 6684.080529] ALSA sound/pci/hda/hda_intel.c:819: send_cmd timeout: IRS=0xffff, val=0x5f0700
    [ 6684.080531] hda-codec: out of range cmd 0:0:5:707:fffffffc
    [ 6684.081377] ALSA sound/pci/hda/hda_intel.c:819: send_cmd timeout: IRS=0xffff, val=0x470d01
    [ 6684.083793] hda-codec: out of range cmd 0:0:5:707:fffffffc
    [ 6684.084126] hda-codec: out of range cmd 0:0:5:707:fffffffc

    I like to disable nvidia-hdmi sound , card 1 ... but i dont know how to do it ..

    I've read the following to get a right config but no solutions
    http://alsa.opensrc.org/index.php/MultipleCards
    https://help.ubuntu.com/community/HdaIntelSoundHowto

    My alsa-base.conf is :

    $cat /etc/modprobe.d/alsa-base.conf
    #options snd slots=snd-hda-intel
    #alias snd-card-0 snd-hda-intel
    #options snd-hda-intel model=auto probe_mask=1 power_save=10 power_save_controller=N
    #options snd-hda-intel model=generic
    #options snd-hda-intel index=0 model=auto
    #options snd cards_limit=1
    #options snd-hda-intel model=3stack-dig
    #options snd slots=snd-hda-intel

    #options snd slots=snd-hda-intel,snd-hda-codec-nvhdmi

    options snd cards_limit=2
    options snd slots=snd-hda-intel,snd-hda-intel
    #options snd-hda-intel=0,1

    #options snd cards_limit=1

    options snd-hda-intel index=0 model=auto probe_mask=1
    options snd-hda-intel index=0 enable_msi=1

    options snd-hda-intel index=1 model=auto probe_mask=2
    options snd-hda-intel index=1 enable_msi=1
    options snd-hda-intel index=1 single_cmd=1
    options snd-hda-intel index=1 bdl_pos_adj=128

    questiones ....

    1) options snd-hda-intel index=0 model=auto how to put alc887 removing "auto"

    2) can i use snd-hda-codec-nvhdmi instead of snd-hda-intel

    3) how to disable hdmi ? can i do it ?

    4) how remove bdl_pos_adj message ?

    thnk you