Hi group,

I am running Fedora 13 on a x86-64 Acer laptop.  Trying to use aplay to play sound files.
Aplay runs but no sound comes out. Mplayer and Play both work OK. If I try to add
-D hw:0,0 I get some error messages. Here is the output:
# play /usr/share/xemacs/xemacs-packages/etc/sounds/say-beep.au


 File Size: 4.03k     Bit Rate: 64.5k
  Encoding: u-law        
  Channels: 1 @ 14-bit  
Samplerate: 8000Hz      
Replaygain: off        
  Duration: 00:00:00.50 

In:100%  00:00:00.50 [00:00:00.00] Out:4.00k [  -===|===-  ]        Clip:0   
# aplay /usr/share/xemacs/xemacs-packages/etc/sounds/say-beep.au
Playing Sparc Audio '/usr/share/xemacs/xemacs-packages/etc/sounds/say-beep.au' : Mu-Law, Rate 8000 Hz, Mono

# mplayer /usr/share/xemacs/xemacs-packages/etc/sounds/say-beep.au
MPlayer SVN-r31628-4.4.4 (C) 2000-2010 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing /usr/share/xemacs/xemacs-packages/etc/sounds/say-beep.au.
Seek failed
libavformat file format detected.
[au @ 0x2552bc0] Estimating duration from bitrate, this may be inaccurate
[lavf] stream 0: audio (pcm_mulaw), -aid 0
Opening audio decoder: [alaw] aLaw/uLaw audio decoder
AUDIO: 8000 Hz, 1 ch, s16le, 64.0 kbit/50.00% (ratio: 8000->16000)
Selected audio codec: [ulaw] afm: alaw (uLaw)
AO: [pulse] 8000Hz 1ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A:   0.2 (00.1) of 0.5 (00.5) ??,?%                                                                
Here is my .asoundrc:
# cat ~/.asoundrc        
pcm.Intel { type hw; card Intel; }
ctl.Intel { type hw; card Intel; }
pcm.!default pcm.Intel
ctl.!default ctl.Intel
Here is the output from aplay -l -L:
# aplay -L -l
    Discard all samples (playback) or generate zero samples (capture)
    PulseAudio Sound Server
    HDA Intel, ALC888 Analog
    Front speakers
    HDA Intel, ALC888 Analog
    4.0 Surround output to Front and Rear speakers
    HDA Intel, ALC888 Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
    HDA Intel, ALC888 Analog
    5.0 Surround output to Front, Center and Rear speakers
    HDA Intel, ALC888 Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
    HDA Intel, ALC888 Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
    HDA Intel, ALC888 Digital
    IEC958 (S/PDIF) Digital Audio Output
    HDA Intel, INTEL HDMI 0
    HDMI Audio Output
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC888 Analog [ALC888 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC888 Digital [ALC888 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 3: INTEL HDMI 0 [INTEL HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
This is what I get when using -D option:
# aplay -D hw:0,0 /usr/share/xemacs/xemacs-packages/etc/sounds/say-beep.au
Playing Sparc Audio '/usr/share/xemacs/xemacs-packages/etc/sounds/say-beep.au' : Mu-Law, Rate 8000 Hz, Mono
aplay: set_params:1053: Sample format non available
Available formats:
- S16_LE
- S32_LE
All that being said, any ideas?? I have googled but have not found the right answer.

Thanks for your time.

William Estrada
Mt Umunhum, CA, USA
HTTP:// ( Mt-Umunhum-Wireless.net )
Skype: MrUmunhum