Mark, No problem there,
Here are the current state of the files after doing as you suggested:

#> lsusb
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 1130:f211 Tenx Technology, Inc. USB audio headset
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 006: ID 05e3:0702 Genesys Logic, Inc. USB 2.0 IDE Adapter
Bus 002 Device 005: ID 03eb:0902 Atmel Corp.
Bus 002 Device 002: ID 046d:c402 Logitech, Inc. Marble Mouse (2-button)
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

#> modprobe.conf {last set of lines}
# ALSA portion
alias char-major-116 snd
alias snd-card-0 snd-usb-audio
options snd-usb-audio id="TenxTech" vid=0x1130 pid=0xf211

# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0

# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

#> cat /proc/asound/cards
 1 [TenxTech       ]: USB-Audio - USB  AUDIO
                      USB  AUDIO   at usb-0000:00:1d.1-1, full speed

#> cat /etc/asound.state
state.TenxTech {
    control.1 {
        comment.access 'read write'
        comment.type BOOLEAN
        comment.count 1
        iface MIXER
        name 'PCM Playback Switch'
        value true
    }
    control.2 {
        comment.access 'read write'
        comment.type INTEGER
        comment.count 2
        comment.range '0 - 17152'
        comment.dbmin 0
        comment.dbmax 0
        iface MIXER
        name 'PCM Playback Volume'
        value.0 1887
        value.1 1887
    }
    control.3 {
        comment.access 'read write'
        comment.type BOOLEAN
        comment.count 1
        iface MIXER
        name 'Mic Capture Switch'
        value true
    }
    control.4 {
        comment.access 'read write'
        comment.type INTEGER
        comment.count 1
        comment.range '0 - 6096'
        comment.dbmin 0
        comment.dbmax 0
        iface MIXER
        name 'Mic Capture Volume'
        value 2032
    }
}


Mark Knecht wrote:
2008/6/28 Michael D. Johnson <mikej163@cableone.net>:
  
I upgraded from Suse 10.3 to Suse 11.0 on Thursday 6/26/08.   The kernel
changed to 2..6.25.5 and with it the /dev setup for the sound.  /dev now has
a subdirectory of snd instead of audio with the pcm dev units and controls.

Everything I had before stopped working.  I've been through the
/etc/modprobe.conf file and and readded the usb product and vendor id
numbers, modprobe and lsmod show that snd-usb-audio is loaded and
/proc/asound/cards show (I think) the right information, but amixer says
there is no audio cards at all.

Is anyone willing to help me troubleshoot this off list?

Mike

    

Mike,
   You can contact me off-list if you prefer. I doubt it will be
necessary and if this is done on-list then you probably get the
benefit of more ideas.

   Not knowing Suse this sounds like a pretty big change. I would
start with alsamixer. Let's erase /etc/asound.state and then run the
command

alsactl store

After doing that does alsamixer find your device? Is it unmuted and
are all the volumes (PCM and master) turned up?

Hope this helps,
Mark