Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Help regarding configuring /etc/asound.conf

Help
Junyun
2011-09-28
2013-06-03
  • Junyun
    Junyun
    2011-09-28

    I am using a linux variant, i586-linux and have the following capture hardware device:
    **** List of CAPTURE Hardware Devices ****
    card 0: Audio , device 0: CS5535 Audio
      Subdevices: 0/1
      Subdevice #0: subdevice #0

    I will like to record from only one channel of the microphone input. When I use arecord -c1 option, it returns a high-pitched and noisy recording. I cannot figure out how to only extract 1 channel out of the 4 available channel inputs for microphones. Does anybody know how I can configure /etc/asound.conf to do that? I tried reading the documentation and use stuff like bindings, but it doesn't seem to work, giving me errors. Any help will be appreciated!

    Thanks,
    Jaedi