Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#708 No sound on ASRock KT7VA4+ /CMI9761

development
open
driver (451)
5
2005-02-16
2005-02-16
Axel Braun
No

This issue was already raised in the alsa-user list,
unfortunately without any result. On the a.m.
motherboard it is impossible to get any sound working
using alsa (sound on knoppix 3.7 works fine, seems that
they are not using alsa)
System is a SuSE 9.2 with alsa drivers 1.0.8
DXS-volumes are turned on, but it is impossible to
unmute PCM (also tried to hit 'm' on PCM-control in
alsamixer, no change). Pls. find state and debug-output
attached.
Thanks

root:~ # cat /proc/asound/card0/codec97#0/*
0-0/0: C-Media Electronics CMI9761

Revision : 0x01
Compat. Class : 0x03
Subsys. Vendor ID: 0xffff
Subsys. ID : 0xffff

Capabilities :
DAC resolution : 16-bit
ADC resolution : 16-bit
3D enhancement : No 3D Stereo Enhancement

Current setup
Mic gain : +0dB [+0dB]
POP path : pre 3D
Sim. stereo : off
3D enhancement : off
Loudness : off
Mono output : MIX
Mic select : Mic1
ADC/DAC loopback : off
Double rate slots: 10/11
Extended ID : codec=0 rev=2 AMAP LDAC SDAC CDAC
DSA=0 DRA
Extended status : SPCV LDAC SDAC CDAC
0:00 = 0000
0:02 = 8000
0:04 = 0000
0:06 = 0000
0:08 = 0000
0:0a = 801e
0:0c = 0000
0:0e = 9f1f
0:10 = 9f1f
0:12 = 0303
0:14 = 0000
0:16 = 9f1f
0:18 = 0808
0:1a = 0000
0:1c = 0000
0:1e = 0000
0:20 = 0000
0:22 = 0000
0:24 = 0000
0:26 = 000f
0:28 = 0bc2
0:2a = 05f0
0:2c = 0000
0:2e = 0000
0:30 = 0000
0:32 = 0000
0:34 = 0000
0:36 = 8080
0:38 = 0080
0:3a = 2a20
0:3c = 0000
0:3e = 0000
0:40 = 0000
0:42 = 0000
0:44 = 0000
0:46 = 0000
0:48 = 0000
0:4a = 0000
0:4c = 0000
0:4e = 0000
0:50 = 0000
0:52 = 0000
0:54 = 0000
0:56 = 0000
0:58 = 0000
0:5a = 0000
0:5c = 0004
0:5e = 0000
0:60 = 0000
0:62 = 0000
0:64 = 3038
0:66 = 0012
0:68 = 0000
0:6a = 0000
0:6c = 0209
0:6e = 0000
0:70 = 0100
0:72 = 0000
0:74 = c000
0:76 = 4955
0:78 = 0000
0:7a = 0000
0:7c = 434d
0:7e = 4983

Discussion

  • Axel Braun
    Axel Braun
    2005-02-16

    result from alsactl -f test.state store

     
    Attachments
  • Logged In: NO

    CMI 9761 problem still exists - I tried alsa versions: 1.0.8
    (from MDV 10.2), 1.0.9, 1.0.10rc1. I only have sound from the
    front speakers. Surround in alsamixer can be only
    muted/unmuted - no level control. I'll send more details if
    necessary. My motherboard: ASROCK k7nf2-raid. All works
    well under windows.