Troubles with CRT HP p1230

Dave Smith
  • Dave Smith
    Dave Smith

      i was running AdvanceMenu and AdvanceMame with my LCD Samsung SyncMaster 940B (19" LCD). I just run advcfg and choose PC Monitor (>30kHz) and then Generic PC SVGA High Res. And in AdvanceMenu configuration file i adjust display_size to 1280. Everything was working fine, all games were running perfectly (mostly i run them in generate-tripple or double so scale filter was used).
    (I'm using framebuffer device).

    But now i brought my CRT monitor which i want to put into my cabbinet and i'm not able to get AdvanceMame running.
    Here are specifications of the CRT:
    Here is output from fbset:
    mode "1600x1200-85"
        # D: 229.516 MHz, H: 106.257 kHz, V: 85.006 Hz
        geometry 1600 1200 1600 1200 8
        timings 4357 304 64 46 1 192 3
        hsync high
        vsync high
        rgba 8/0,8/0,8/0,0/0

    I tested advcfg with 5-150 / 30-140 / 50-160 as clock settings in custom section, but no luck.
    I'm still unable to start any game, i usualy get Out of sync message on monitor, and something that FV (freq vert) is about 250Hz.
    I was trying to modify that clock custom line, also to count some timins etc, but without any luck.
    I would appreciate any help.
    What to put into advmame.rc or what values to advcfg so roms will start working with my CRT as they used to with LCD.
    I was able to run AdvanceMenu, but that's all. AdvanceMame is not working :o(((.

    Thank you very much,

    • tkb101

      1. bring down


      to just 1024 or 800

      2. try the most conservative setting for your pc crt:

      device_video_clock 5-150 / 31.5 / 55-130
      - this works for most of my pc crt's.

      3. ideally, your clock settings should look like:

      device_video_clock ???-420 / 30-140 / 50-160

      you'll have to guess/research more  the minimum pixelclock  for your monitor.

      4. if using advcfg.exe, choose the minimum default setting for your display type (pc crt, vga). if you get a black screen on the testing stage, ignore the OSD message from your monitor and press "enter" to save the config anyway. hopefully advcfg.exe did not spit out error messages. if the setting was accepted and saved into advmame.rc, try it out with advmame.exe.

      5. advmame was programmed for old hardware, so use older hardware. for video cards, any nvidia 8mb - 64mb works well (personally tested with the dos version).

    • Dave Smith
      Dave Smith

      Ok i'll test it.
      I'm running advmame on linux not on windows. But we will see.
      I have Radeon 9600 card.
      But as i said in post before, with LCD 19" it's working like charm, problem is in setting up that CRT.
      I'll test it and let know if it works.
      In other case i'll have to find another CRT.

    • Dave Smith
      Dave Smith

      Ok finaly i got it working. Seems that this CRT is not able to work with lowest resolution of games.
      So i have to put this line for each game in advmame.rc

      <rom_name>/display_mode generate-double

      so for ex:
      mslug2/display_mode generate-double

      then it works like a charm.