Problem with Adminer Editor after Open-SSL upgrade

Help
2014-04-09
2014-04-13
  • Hi everybody!

    I'm working on Ubuntu 12.04.4 LTS (GNU/Linux 3.2.0-60-virtual x86_64); yesterday an important security upgrade was made, replacing all the packages you can find below.

    Today Adminer Editor doesn't work anymore.

    If I try to login with a wrong password, it reply with the correct response; but, if I try to login with the right username and password it hangs, and Apache logs report:

    [Wed Apr 09 10:15:02 2014] [error] [client 94.87.16.162] PHP Fatal error: Call to a member function quote() on a non-object in /mnt/sites/adminedit/htdocs/index.php on line 45, referer: http://adminedit.eutheneia.it/?username=egim_900

    Nothing else was changed on the server.

    Any suggestion?

    Many thanks!!

    Roberto Tognelli

    2014-04-01 08:46:53 upgrade libudev0 175-0ubuntu9.4 175-0ubuntu9.5
    2014-04-01 08:46:53 upgrade udev 175-0ubuntu9.4 175-0ubuntu9.5
    2014-04-01 08:46:54 upgrade linux-firmware 1.79.10 1.79.11
    2014-04-01 08:46:57 upgrade cloud-init 0.6.3-0ubuntu1.11 0.6.3-0ubuntu1.12
    2014-04-01 08:46:58 upgrade grub-legacy-ec2 0.6.3-0ubuntu1.11 0.6.3-0ubuntu1.12
    2014-04-04 17:26:22 upgrade libyaml-0-2 0.1.4-2ubuntu0.12.04.2 0.1.4-2ubuntu0.12.04.3
    2014-04-08 10:24:11 upgrade libssl1.0.0 1.0.1-4ubuntu5.11 1.0.1-4ubuntu5.12
    2014-04-08 10:24:14 upgrade file 5.09-2ubuntu0.2 5.09-2ubuntu0.3
    2014-04-08 10:24:14 upgrade libmagic1 5.09-2ubuntu0.2 5.09-2ubuntu0.3
    2014-04-08 10:24:14 upgrade openssh-server 1:5.9p1-5ubuntu1.2 1:5.9p1-5ubuntu1.3
    2014-04-08 10:24:15 upgrade openssh-client 1:5.9p1-5ubuntu1.2 1:5.9p1-5ubuntu1.3
    2014-04-08 10:24:16 upgrade openssl 1.0.1-4ubuntu5.11 1.0.1-4ubuntu5.12
    2014-04-08 10:24:16 upgrade php5-cli 5.3.10-1ubuntu3.10 5.3.10-1ubuntu3.11
    2014-04-08 10:24:17 upgrade php5-intl 5.3.10-1ubuntu3.10 5.3.10-1ubuntu3.11
    2014-04-08 10:24:17 upgrade php5-mysql 5.3.10-1ubuntu3.10 5.3.10-1ubuntu3.11
    2014-04-08 10:24:18 upgrade php5-curl 5.3.10-1ubuntu3.10 5.3.10-1ubuntu3.11
    2014-04-08 10:24:18 upgrade php5-gd 5.3.10-1ubuntu3.10 5.3.10-1ubuntu3.11
    2014-04-08 10:24:18 upgrade libapache2-mod-php5 5.3.10-1ubuntu3.10 5.3.10-1ubuntu3.11
    2014-04-08 10:24:19 upgrade php5-common 5.3.10-1ubuntu3.10 5.3.10-1ubuntu3.11
    2014-04-08 10:24:19 upgrade php5 5.3.10-1ubuntu3.10 5.3.10-1ubuntu3.11

     
  • Jakub Vrána
    Jakub Vrána
    2014-04-13

    This looks like a bug introduced in Adminer 4.0.0 and fixed in Adminer 4.1.0. Either wait for release of this version or use the development version.