Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

LDAP SSL, Server 2008, ldap_bind hangs

Wil Wade
2012-01-16
2013-05-20
  • Wil Wade
    Wil Wade
    2012-01-16

    Ok I am having a strange issue.

    Old Windows 2000 AD server, ssl ldap connect fine.

    Ubuntu Webserver, Apache 2.2.17, PHP 5.3.5-1ubuntu7.4

    New Windows 2008 AD server, new domain, ldap connect OK, ssl ldap fail

    Ok so my webserver is working fine with my old 2k server ldap ssl works great.

    I setup my new Win2k8 server and on the server I have no trouble connecting using ldp.exe and ssl, binds with the ldap user account everything.

    When I use non-ssl ldap from my ubuntu server it connects great. When I turn on my ssl, it does actually connect according to the log, but right after the ldap_bind the server no longer sends any response. It will just timeout with no response.

    Any ideas?

    I have setup in the adldap script to show any possible errors, but no errors are given, and no response from the server after the ldap_bind. The trace appears to indicate that the php script does continue, but no output. In fact the login works if I hit the server on a different page. Weird I know.

     
  • Wil Wade
    Wil Wade
    2012-01-17

    Ok so I even ran an ldapsearch on another Linux server (running identical version of openldap mind) and it works.

    When I run the same ldapsearch command on my webserver it gets through everything and then hangs. Apparently this is a very tiny bug in openldap.

     
  • Wil Wade
    Wil Wade
    2012-01-17

    FYI

    I moved that server from openldap 2.4.23 (stable) to 2.4.28  (release) and the problem went away.