RUN_ImportAdempiere

2011-11-15
2013-03-07
  • Ciao a tutti,
    sono in una fase di testing di questo prodotto, e non riuscendo ad installare il database con RUN_ImportAdempiere, perchè mi restituisce questo errore:

    Setting myEnvironment ….
    Re-Create Adempiere User and import C:\Adempiere\data\Adempiere.dmp - (xe)
    Il volume nell'unità C non ha etichetta.
    Numero di serie del volume: 56CB-8444

    Directory di C:\Adempiere\data

    14/06/2010  20:21        31.580.160 Adempiere.dmp
                   1 File     31.580.160 byte
                   0 Directory  53.324.001.280 byte disponibili
    == The import will show warnings. This is OK ==
    Premere un tasto per continuare . . .
    Adempiere Database Import               $Revision: 1.3 $
    Importing Adempiere DB from C:\Adempiere\data\Adempiere_pg.dmp (xe)


    Re-Create user and database

    "dropdb" non è riconosciuto come comando interno o esterno,
    un programma eseguibile o un file batch.
    "dropuser" non è riconosciuto come comando interno o esterno,
    un programma eseguibile o un file batch.
    "psql" non è riconosciuto come comando interno o esterno,
    un programma eseguibile o un file batch.
    "createdb" non è riconosciuto come comando interno o esterno,
    un programma eseguibile o un file batch.


    Import Adempiere_pg.dmp

    "psql" non è riconosciuto come comando interno o esterno,
    un programma eseguibile o un file batch.
    "psql" non è riconosciuto come comando interno o esterno,
    un programma eseguibile o un file batch.
    "psql" non è riconosciuto come comando interno o esterno,
    un programma eseguibile o un file batch.
    Premere un tasto per continuare . . .

    Volevo quindi chiedervi una dritta:
    Il sistema è Windows 7 64it
    PostGreSQL 9.1
    Java SDK 1.5.0_22

    JAVA_HOME = C:\Program Files (x86)\Java\jdk1.5.0_22
    Path PostGreSQL = C:\PostGres

    Grazie

     
  • Angelo Dabalà
    Angelo Dabalà
    2011-11-16

    Ciao,

    devi aggiungere il percorso della cartella bin di postgres al path, nel tuo caso dovrebbe essere C:\PostGres\9.1\bin

    Questo dovrebbe risolvere il problema

    Saluti,
    Angelo

     
  • Ciao Angelo,
    ho provato come mi hai indicato, per la precisione ho aggiunto come variabile d'ambiente di sistema:
    POSTGRES_HOME=C:\PostGreSql\bin\
    ma il risultato non cambia.
    Cos'altro potrebbe essere

     
  • Ciao Angelo,
    forse sono riuscito dovevo aggiungere  C:\PostGreSql\bin\
    nella variabile Path e non crearne una come sopra.

     
  • Angelo Dabalà
    Angelo Dabalà
    2011-11-17

    Esatto :)

     
  • Ciao Angelo,
    sai dove posso trovare un link eplicativo (poss in italiano) dove viene spiegata passo passo l'installazione?
    Quella in inglese sul sito Adempiere, mi pare un po' scarna e poi essendo poco pratico di applicazioni Java ogni tanto faccio delle catronerire come quella sopra del Path.

     
  • Angelo Dabalà
    Angelo Dabalà
    2011-11-17

    Non mi risulta che ci siano istruzioni in italiano. Per i neofiti un buon punto di partenza sono i libri che trovi nella home page del wiki, "ADempiere 3.4 ERP Solutions" e "ADempiere 3.6 Cookbook" (specialmente il primo). Anche se sono in inglese, sono piuttosto semplici da seguire e corredati da molte illustrazioni, ti possono dare molte risposte senza dover ricorrere al forum.

    Esiste un'installazione automatizzata per Windows, la puoi trovare seguendo questo link

    http://www.adempiere.com/Windows_Installer

    io non l'ho mai provata, non ti so dire se funziona senza problemi, so che si deve evitare di installare su cartelle che contengono spazi nel percorso.

    Se invece preferisci seguire l'installazione passo passo, puoi leggere le istruzioni a questo link

    http://www.adempiere.com/Adempiere_Install_for_Windows_%26_PostgreSQL

    Mi sembra comunque che sei a buon punto, se hai fatto il RUN_Setup.bat e l'importazione del DB. Certo se vuoi capire dettagliatamente cosa fa l'installazione ti ci vorrà un po di tempo.

    Se invece vuoi solo "dare un'occhiata" ad ADempiere, puoi anche utilizzare i siti per la prova online

    www.testadempiere.com/webui/

    oppure scaricare una macchina virtuale già configurata

    Saluti,
    Angelo

     
  • Ciao Angelo,
    ti ringrazio per le informazioni.
    Da quello che ho capito la versione in italiano 360_Laura dovrebbe essere,oltre alla localizzazione, anche funzionale per la normativa italiana, puoi confermarmi questo?
    Poi ho un punto in cui sono ancora fermo: eseguendo RUN_Adempiere, mi si apre la finestra di connessione, dove dovrei inserire l'host ho da indicare Host dell'applicativo (MyAppsServer) e inserendo il Nome PC o indirizzo IP del pc cliccando su Applicazione di test mi restituisce l'errore Server non attivo - Could not obtain connection to any to these urls… ecc. cosa dovrei fare?
    Comunque cercherò di seguire anche quello che mi hai indicato.

     
  • Ho seguito tutte le istruzioni che mi ha segnalato Angelo, ma sono fermo al RUN_Server2.bat che a meta circa mi segnala:
    Failed to boot JBoss:

    vedi qua sotto

    C:\Adempiere\utils>RUN_Server2.bat
    Setting myEnvironment ….
    Start Adempiere Apps Server C:\Adempiere (adempiere)
    ===============================================================================

      JBoss Bootstrap Environment

      JBOSS_HOME: C:\Adempiere\jboss

      JAVA: C:\Program Files (x86)\Java\jdk1.5.0_22\bin\java

      JAVA_OPTS: -server -Xms64M -Xmx512M -DADEMPIERE_HOME=C:\Adempiere  -Dorg.ademp
    iere.server.embedded=true -Dprogram.name=run.bat -server -Xms128m -Xmx512m -XX:M
    axPermSize=128m -Dsun.rmi.dgc.client.gcInterval=3600000 -Dsun.rmi.dgc.server.gcI
    nterval=3600000

      CLASSPATH: C:\Program Files (x86)\Java\jdk1.5.0_22\lib\tools.jar;C:\Adempiere\
    jboss\bin\run.jar

    ===============================================================================

    19:48:32,056 INFO   Starting JBoss (MX MicroKernel)…
    19:48:32,057 INFO   Release ID: JBoss  4.2.3.GA (build: SVNTag=
    JBoss_4_2_3_GA date=200807181417)
    19:48:32,059 INFO   Home Dir: C:\Adempiere\jboss
    19:48:32,059 INFO   Home URL: file:/C:/Adempiere/jboss/
    19:48:32,060 INFO   Patch URL: null
    19:48:32,061 INFO   Server Name: adempiere
    19:48:32,061 INFO   Server Home Dir: C:\Adempiere\jboss\server\adempiere

    19:48:32,062 INFO   Server Home URL: file:/C:/Adempiere/jboss/server/ade
    mpiere/
    19:48:32,063 INFO   Server Log Dir: C:\Adempiere\jboss\server\adempiere\
    log
    19:48:32,063 INFO   Server Temp Dir: C:\Adempiere\jboss\server\adempiere
    \tmp
    19:48:32,064 INFO   Root Deployment Filename: jboss-service.xml
    19:48:32,321 INFO   Java version: 1.5.0_22,Sun Microsystems Inc.
    19:48:32,322 INFO   Java VM: Java HotSpot(TM) Server VM 1.5.0_22-b03
    ,Sun Microsystems Inc.
    19:48:32,323 INFO   OS-System: Windows 7 6.1,x86
    19:48:32,589 INFO   Core system initialized
    Failed to boot JBoss:
    org.jboss.deployment.DeploymentException: url file:/C:/Adempiere/jboss/server/ad
    empiere/conf/jboss-service.xml could not be opened, does it exist?
            at org.jboss.deployment.DeploymentInfo.<init>(DeploymentInfo.java:214)
            at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:781)
            at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:766)
            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
            at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
    java:39)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
    sorImpl.java:25)
            at java.lang.reflect.Method.invoke(Method.java:592)
            at org.jboss.mx.interceptor.ReflectedDispatcher.invoke(ReflectedDispatch
    er.java:155)
            at org.jboss.mx.server.Invocation.dispatch(Invocation.java:94)
            at org.jboss.mx.interceptor.AbstractInterceptor.invoke(AbstractIntercept
    or.java:133)
            at org.jboss.mx.server.Invocation.invoke(Invocation.java:88)
            at org.jboss.mx.interceptor.ModelMBeanOperationInterceptor.invoke(ModelM
    BeanOperationInterceptor.java:142)
            at org.jboss.mx.server.Invocation.invoke(Invocation.java:88)
            at org.jboss.mx.server.AbstractMBeanInvoker.invoke(AbstractMBeanInvoker.
    java:264)
            at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:659)
            at org.jboss.mx.util.MBeanProxyExt.invoke(MBeanProxyExt.java:210)
            at $Proxy5.deploy(Unknown Source)
            at org.jboss.system.server.ServerImpl.doStart(ServerImpl.java:482)
            at org.jboss.system.server.ServerImpl.start(ServerImpl.java:362)
            at org.jboss.Main.boot(Main.java:200)
            at org.jboss.Main$1.run(Main.java:508)
            at java.lang.Thread.run(Thread.java:595)
    19:48:32,625 INFO   Runtime shutdown hook called, forceHalt: true
    19:48:32,626 INFO   JBoss SHUTDOWN: Undeploying all packages
    19:48:32,635 INFO   Shutdown complete
    Shutdown complete
    Halting VM
    Done Adempiere Apps Server C:\Adempiere (adempiere)

     
  • e in effetti il file C:/Adempiere/jboss/server/adempiere/conf/jboss-service.xml non esiste, c'è solo il template: C:/Adempiere/jboss/server/adempiere/conf/jboss-serviceTemplate.xml
    Dove/come viene creato/modificato questo file?

     
  • Angelo Dabalà
    Angelo Dabalà
    2011-11-18

    Hai lanciato il RUN_setup.bat prima? Quello serve a configurare ADempiere e crea il file che ti manca (più altri) partendo dal template. Ho notato che usi la JDK1.5, se non ricordo male a partire dalla versione 360 ADempiere richiede la JDK1.6.
    Se hai lanciato il setup, quello crea un log nella cartella principale (c:\adempiere nel tuo caso) verifica che non ci siano errori

    Saluti
    Angelo

     
  • In effetti con la JDK1.6 ho fatto un passettino avanti.
    Aprendo però l'URl dell'applicazione: http://pc_app/admin mi viene restituito questo:
    HTTP Status 404 - /admin


    type Status report
    message /admin
    description The requested resource (/admin) is not available.


    JBossWeb/2.0.1.GA

    Prometto che alla fine metto on line i miei appunti in italiano sull'installazione.

     
  • Allora, ora mi si è aperto.
    Non so come mai, avevo il servizio Adempiere avviato (in automatico) l'ho arrestato, ho lanciato RUN_Server2.bat e si è avviato.
    Ora vedo se riesco ad impostatre la lingua italiana.

     
  • Angelo Dabalà
    Angelo Dabalà
    2011-11-18

    Bisogna controllare i log di jboss (/Adempiere/jboss/server/adempiere/log/)

    boot.log
    server.log

    qualcosa dev'essere andato storto in fase di deploy dell'applicazione, verifica ad esempio che postgres accetti connessioni dall'ip della macchina, di default credo consenta solo connessioni a localhost (127.0.0.1)

    Angelo

     
  • amico buona giornata, se si desidera installare TeamViewer sul vostro computer e www.teamviewer.com posso dare assistenza remota con l'installazione

     
  • Ciao Angelo,
    grazie ancora per la tua disponibilità.
    Al momento sono riuscito ad entrare nell'applicativo. Ho controllato i due log che mi hai segnalato e non mi pare ma a parte alcuni errori sull'invio delle email (forse le mail non sono corrette).
    Non riesco però a capire come applicare la lingua italiana (che ho scaricato da adempiereitalia) e la localizzazione.
    Mi manca ancora qualche file? Ho visto sulla documentazione che dovrebbero esserci dei file xml localizzato it_IT, ma nei file zip non ho trovato.
    :-(

     
  • Angelo Dabalà
    Angelo Dabalà
    2011-11-18

    Ciao,

    l'argomento traduzioni è stato sviscerato nel thread seguente:

    https://sourceforge.net/projects/adempiere/forums/forum/623956/topic/4481064

    ti consiglio di leggere tutti i post, dovresti farti un'idea di come procedere.

    Comunque se hai scaricato la localizzazione da ADempiere Italia il dump del database comprende già la traduzione italiana (anche se forse non aggiornatissima)

    Angelo

     
  • Come posso collaborare per aggiornare la traduzione?

     
  • Angelo Dabalà
    Angelo Dabalà
    2011-11-18

    Al momento non viene utilizzata alcuna piattaforma collaborativa per la traduzione, quella su Launchpad non è mai decollata :)
    Quello che puoi fare è lavorare ad uno dei file xml che non sia già stato tradotto e poi magari caricarlo qui su SF nella sezione dei contributi. Oppure più semplicemente puoi segnalare eventuali errori e/o imprecisioni o suggerire miglioramenti, possibilmente aprendo un thread apposito.

    Angelo

     
  • Non capisco cosa succede:
    Ho rimosso il servizio Adempiere, tramite il comando contentuto nella utils/windows. Ora se lancio RUN_Server2.bat, Adempiere si avvia (da web) e sembra funzionare. Per comodità volevo reimpostarlo come servizio automatico, quindi ho lanciato l'apposito .bat nella cartella di cui sopra. Il servizio è ora presente come manual, lo modifico in automatico e lo avvio (cerco di avviarlo) ma si interrompe con un avviso che dice che è stato avviato, quindi è stato arresato. Alcuni servizi ecc. Come mai?
    Poi non mi è chiaro come applicare la localizzazione italiana, al momento sono riuscito sono ad applicare solo la traduzione, non so se occorre caricare un piano dei conti oppure i file di localizzazione presenti sul sito Adempiere Italia come vanno applicati?
    Quale sequenza è meglio usare? Ci sono diversi file sul sito: conviene usare solo il dump del DB, è sufficiente? La versione 360LTS Laura Edition scaricata è già impostata con un piano di conti italiano?
    Mi rendo conto che avrei dovuto un thread a parte, ma per questa volta perdonatemi, avevo già scritto tutto.