Cannot run in eclipse java hotspot....

Developers
2012-11-07
2013-03-08
  • Ronel Cabrera
    Ronel Cabrera
    2012-11-07

    java hotspot(TM) 64-bit server VM -1.7.0_09 <> 1.5.0 occured when I ran adempiere in eclipse.

    I recently downloaded the source and ran it but then an error occurred. What does this mean? How do I fix this? I am using eclipse Indigo and I have installed jdk 1.7 and jdk 1.6 already.

    Please help.

    Regards,
    Ronel C.

     
  • Ronel Cabrera
    Ronel Cabrera
    2012-11-10

    Anyone on this?

     
  • Mario Calderon
    Mario Calderon
    2012-11-11

    hi Ronel,
    this is the case when the java you are running on Eclipse is different than the one installed in your system.

    I got the error you mention when changing to java 1.7 due to testing Adempiere 3.7.1.
    Also, clean the build to get rid of all the all compiled files.

    Best regards,
    Mario Calderon

     
  • Ronel Cabrera
    Ronel Cabrera
    2012-11-18

    clean build? I don't quite understand. Sorry, but how do I clean the build?

    Thanks for the reply.

     
  • Mario Calderon
    Mario Calderon
    2012-11-25

    hi,
    it means

    - open the Ant View in Eclipse
    - create a new build file, choosing ……/trunk/utils_dev/build.xml
    - run the clean tag.

    This delete all compiled files and starts the compiling anew.

    Sometimes, the properties of the project has the old JRE even if you have installed a new JRE in Eclipse. You check it with
    - Project properties
    - select Java Build Path
    - Horizontal tab Libraries

    The JRE library is at the end.

    Best regards,
    Mario