ABP Puts a C: in front of My backup.path

Help
Peter Jam
2009-07-17
2013-04-26
  • Peter Jam
    Peter Jam
    2009-07-17

    I have tried to get Another Backup Program 1.11.0.0 to copy a backup to several places; E: P: etc.  It always puts a c: infront of that path and I don't know what I am doing wrong?  It says: Backup of ".... to "C:\P:\Backups\Database.kdb" failed.  The filename, directory name, or volume label syntax is incorrect.  of course it is, I didn't put a C:\ in front of the P:\, where did it come from?

     
    • Bill Rubin
      Bill Rubin
      2009-07-19

      That's puzzling, especially since ABP works correctly for many people.  My guess is that there's something wrong with your command line argument.  Could you post the exact command line argument you pass to ABP?

      Bill Rubin

       
      • Peter Jam
        Peter Jam
        2009-07-20

        sorry, I meant to do that last week and didn't.
        It is:
        "C:\Program Files\KeePass Password Safe\KeePass.exe" "C:\Documents and Settings\slospjam\My Documents\Personal-docs\Database.kdb" /backup.path:"\P:\Backups\"

         
        • Peter Jam
          Peter Jam
          2009-07-20

          You are correct, I totally missed that.  Works great.  Thanks for your patience.
          Peter

           
    • Bill Rubin
      Bill Rubin
      2009-07-20

      Your backup path command line argument should read    /backup.path:"P:\Backups\". 

      See the "shourtcuts" example at http://abp-keepass.sourceforge.net/Installation.html#configure

      The initial backslash you coded says to Windows, "Go to the root of the current directory path."  Your current directory was presumably on the C-disk.  That's why Windows interpreted your path as being on the C-disk.  This is standard Windows behavior, and is not something coded in ABP.

      Bill Rubin

       
      • Peter Jam
        Peter Jam
        2009-07-20

        I changed my Properties to:
        "C:\Program Files\KeePass Password Safe\KeePass.exe" /backup.path:"\P:\Backups\"

        I don't get the error anymore, but I don't get a backup either?

        thanks in advance,
        Peter

         
    • Bill Rubin
      Bill Rubin
      2009-07-20

      Apparently you didn't understand my last post.  All you had to do was to remove a single character -- the initial backslash -- from your original properties target.

      Bill Rubin