Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

ExportDV problem

Developers
2008-09-03
2013-04-29
  • Random_Access
    Random_Access
    2008-09-03

    I'm trying the exportDV example from AAF sdk 1.1.3 (got the same problem in 1.1.2 as well)
    I think the program runs fine.

    My input arguments are:  -o example.aaf -rawDV sample.dv

    The output is:

    Creating output in NTSC format.
    Creating file example.aaf using WriteSamples with CompressionDisable
      using codec flavour "AAF CDCI Codec (IEC DV 525 lines 60Hz)"
    Wrote 286 samples
    DONE

    The problem is that, this file is not recognized as a valid AAF. (I tried it on Sony vegas).

    The input file that i have used is a dv file.
    details: File Type: Raw DV - IEC 61834 (.DV)

     
    • Without knowing what Sony Vegas considers to be a valid AAF it’s impossible to tell what it doesn’t like about the file generated by ExportDV.

      I would suggest reverse engineering of sorts. Export DV media from Vegas to AAF and then try to create identical metadata structures in your own file.

      Before you do that though, try running ExportDV with the ‘-legacyDV’ option. It generates an AAF using older Structured Storage format and with legacy metadata.

       
      • Random_Access
        Random_Access
        2008-09-05

        I checked the file in Adobe premiere pro also. It accepts the aaf file, but when you play it, through out its duration it shows a red screen written with " MEDIA OFFLINE ". Also, I noticed that in Sony vegas, when you see the file details, it gives the correct duration, sample rate, etc by in "Media type" it shows offline.

         
        • Phil Tudor
          Phil Tudor
          2008-09-12

          Do you know if Vegas or Premiere claims to extract media from an AAF file? I *think* those applications primarily use AAF as a composition metadata format. The latest versions of Premiere add *MXF* media support to that (so you could have an AAF composition metadata file referencing an MXF media file).

          So your file could be good, but the applications you're reading it with aren't attempting to pull out embedded media. Does an Avid read it - Avid extracts embedded AAF media.

          Phil

           
    • Random_Access
      Random_Access
      2008-09-11

      Tried with the -legacyDV option too. Gives the same results.
      I've tried all possible formats, but I'm getting the same result.
      I think, there could be a codec problem.
      Is there a method to change the codecs mentioned in the program ?

       
      • 'Codec' refers to an AAF codec like those implemented in the AAFStandardCodecs project. There's only one AAF codec that handles DV.

        Because the frames you're supplying are already DV-encoded there's no encoding actually happening, the codec simply wraps the provided DV stream in AAF.

        This does not mean that the essence steam is not a problem but I wouldn’t bother looking there until I was sure that the metadata is correct.