Mike Christie wrote:
> Erez Zilber wrote:
>> A patch to linux-iscsi HEAD is attached.
>> the Patch is merged from linux-iscsi-4-2-branch and adds the DataMover
>> API to the current iSCSI implementation
>> The DataMover API (derived from the IETF iSCSI DA Draft) allows
>> different transports such as TCP, iSER (iSCSI RDMA), and TOE (TCP
>> Offload) to be placed under the core iSCSI implementation and provide
>> significant performance acceleration and Zero Copy.
>> the current Drop includes a TCP Datamover and an API for additional
>> In the future we will also add the iSER Datamover code that will allow
>> working over any RDMA hardware
>> best regards
> Is it your intention to get this merges one day? If so, you should start
> off with
> the basics like:
> - make your patch with -u
> - follow the kernel coding style in all files. you should also read greg
> kh's guide for this.
> don't add your own formatting to the existing files.
> - remove all the code that is not being used.
> - Also when you cut and paste a bunch of code, and that code is pretty much
> the entire file you may want to add some sort of attribution for the code
> you just took.
> - what is iscsi-net-pdumover.c? Why did you move the core xmit IO
> code there, but left the recv equivalents in iscsi-recv-pdu.c.
> - And are you going to post more examples of iscsi_net_pdumover_ops?
> When do you
> plan to have the other kernel code that it would use in mainline. Our
> is not written in stone so.
> I am sick right now, so I do not have time to review this in depth and this
> is not something a Cisco ACK is good enough for, and will get to
> it once you do the initial cleanup - if your goal is to merge it one day
> that is.
Oh yeah some other quick notes to help you out.
- If you change the function prototypes and move some things
around you can and should not have this:
.send_general = iscsi_net_pdumover_send_general,
.send_command = iscsi_net_pdumover_send_command,
.send_data_out = iscsi_net_pdumover_send_data_out,
Instead we can just move to
.send_general = iscsi_net_pdumover_send_general
But could you also rename this to just .send_pdu? and could you
not name functions with the iscsi_net_pdumover_ prefix? it is
kinda a little long. Also I do not think this is in the coding
style docs, but could you make functions static where they should be.
>> /*Erez Zilber*/
>> /*Software Engineer*/
>> /*T 972-9-9717689*/
>> /*www.voltaire.com*/ <http://www.voltaire.com/>
>> /*The Grid Interconnect Company*/
> This SF.Net email is sponsored by: IntelliVIEW -- Interactive Reporting
> Tool for open source databases. Create drag-&-drop reports. Save time
> by over 75%! Publish reports on the web. Export to DOC, XLS, RTF, etc.
> Download a FREE copy at http://www.intelliview.com/go/osdn_nl
> linux-iscsi-devel mailing list