Chuck Esterbrook wrote:
> Two suggestions.
> 1. Regarding the name of "extraPathInfo()" two thoughts come to mind. One
> is that there are always two kinds of paths with regards to requests: the
> URL path and the corresponding server side path. Most of our other path
> methods (maybe all of them) indicate this (urlPath(), serverSidePath()).
> Also, in my experience a method with "info" as a suffix usually returns
> some kind of a information in a tuple or dictionary, like sys.exc_info() or
> In light of this, I'd like to see the method called "extraURLPath()" or
> something similar.
_extraPathInfo is the variabele name used internally,
so extraPathInfo() is not a bad choice, but according to the
Webware policy guide extraURLPath() seems a more natural name.
Stuff like self._extraPathInfo = None
should be changed accordingly after a methot name change,
otherwise it would be somethat confusing..
If this name is going to be changed, just do it fast, because I'm
writing about Webware today and will use this for examples :-)
'ExtraPathInfo' : 1, #comment
the comment is not in one line which stops
Webware from starting (small bug in the CVS version),
otherwise it seems to works nicely and has the same performance..
In any case, this new code is really cool.
> 2. I wouldn't be opposed to Page.writeHeader() checking the setting
> concerning extra URL paths and generating the BASE HREF automatically. This
> is the type of convenience Page is intended to provide.
the method should be overridable in a subclass, because the
behaviour is not that odd as it seems first
def writeHeader(self, ...):
default behaviour: write the BASE HREF
just my 2 cents