On Thursday 28 September 2006 22:00, Oleg Broytmann wrote:
> On Thu, Sep 28, 2006 at 09:16:49PM +0300, Dan Pascu wrote:
> > I think the original's poster patch is the right thing to do.
> Better to say "it could have more sense". Unfortunataly, one-line
> patch near .style.dbColumnToPythonAttr() looked for me like a quick and
> dirty hack, like a shortcut over proper SQLObject path. I could be
> wrong, of course, but that was my impression.
You can twist the expressions all you like, but IMO if fromDatabase is
used, the database field names should come from the database not from a
name style mapper.