Just wanted to see if there are any objections to something I'm
considering doing next week...
CompositionModel is an abstract interface class. However, there is
only one class that implements the interface, CompositionModelImpl. To
me, an abstract class with only a single deriver is extra code to read
that doesn't add anything. Does anyone have any objections to me
getting rid of the abstract interface CompositionModel and renaming the
concrete CompositionModelImpl to CompositionModel? (Actually combining
the two as we can't just get rid of CompositionModel which contains some
important typedefs and whatnot.)
I'm not sure that I'm actually going to follow through, but if anyone
else agrees, that might push me in that direction.