On Thu, Dec 17, 2009 at 03:02:51AM +0100, Rafał Miłecki wrote:
> V2: reorganize functions, fix modesetting calls
> V3: rebase patch, use radeon's workqueue
> V4: enable on tested chipsets only, request VBLANK IRQs
> V5: enable PM on older hardware (IRQs, mode_fixup, dpms)
> V6: use separate dynpm module parameter
> Tested on my M82==RV620 and my new M96==RV730. Also tested on RV515 by
> Sedat where already posted patch for AtomBIOS's mutex was needed.
I think it would be better to change :
RADEON_PM_ACTION_NONE -> PM_NONE ...
We already know we are in the radeon module so this is redundant
to put it in the name again. And i don't think PM_NONE will conflict
with other kernel symbol. Same apply to all other name.
I wish to convert radeon module to use dev_err, dev_info, ... instead
of DRM_DEBUG, DRM_INFO. Motivation behind that is multi GPU computer.
It's not common yet but i think we will want to support that in the
Convertion to match this can be done as a latter patch. There is
few things that might be improved but that shouldn't matter that