On Friday, December 13, 2002, at 08:26 PM, Stuart Donaldson wrote:
> I have noticed a couple of places where New and Old are used to
> identify improved and out-dated methodologies.
> NewThreadedAppServer, serverSideInfoForRequestNew and
Yes, those are all me. Probably bad naming. Yes, the names are
definitely not meant to be left in there -- I couldn't decide whether to
create alternate methods/classes or replace the ones that were there. I
named them extra crappily so a choice would have to be made ;)
serverSideInfoForRequestNew should probably be renamed now, since I
think it's gotten enough testing (and its accompanied methods, like
filenamesForBaseNameNew). NewThreadedAppServer could use a bit more
testing, at which time I'd like to be able to replace
ThreadedAppServer... though maybe I should just name it
MultiPortAppServer, leave ThreadedAppServer in there, and Official
Adoption will just mean changing the AppServer scripts to reference it
and not ThreadedAppServer...