> configure: error: Library requirements (gtk+-2.0 >= 2.0.0 libxml-2.0
> >= 2-2.4.24 sigc++-1.2 gtkmm-2.0 ) not met; consider adjusting the
> PKG_CONFIG_PATH environment variable if your libraries are in a
> nonstandard prefix so pkg-config can find them.
> I know I have gtkmm1.2 installed and than I need then to install 2.0,
> but the question is: inkscape 0.38 did NOT require neither gtkmm1.2 nor
> 2.0. I thought this would be necessary from 0.40 and onward, not
> before. When was this changed, or what did I miss?
It looks to me as if gtkmm isn't used (other than in the ecma directory,
which isn't used yet).
in configure.in (if you have autoconf installed) or configure
(if you don't).
Let us know how you go. I suggest writing just to
inkscape-devel@... rather than inkscape-user.
> Also, which gtkmm should I install: 2.0-2.2, or 2.4 ?
If you find that you do need gtkmm, then install 2.2 or 2.0.
gtkmm 2.4 may be necessary for inkscape 0.40, but I'd guess that it
won't work for inkscape 0.39.