On Thu, Sep 18, 2003 at 03:16:55PM +0100, Sam Clegg wrote:
> Hi guys..
> I just finished my MSc and so I now have more time to play
> with my iPod.
> I would like to make some superficial but widespread changes to
> gtkpod to make it simpler to navigate. I'll number them so
> we can discuss them separately.
> 1: I'd like to add $id$ to every source file in the header.
What is $id$? If it's useful, yes. I'd like to keep the timestamp (set
by emacs automatically), however.
> 2: I'd like to make the global naming cleaner and more modular.
> I've started with playlists. My new playlists.h looks like this:
> void pl_create_mpl ();
> Playlist* pl_add_new (gchar *plname, gint position);
> void pl_free (Playlist *playlist);
> Playlist* pl_add_playlist (Playlist *plitem, gint ylist *playlist, gint pos);
> void pl_remove (Playlist *playlist);
> void pl_remove_all ();
> Note the indentation, naming conventions and shorter function
> names. I have these changes made locally and can commit them if
> nobody objects.
I've been trying to work toward a more consistent naming convention
but didn't push it too hard. So I would welcome your effort. The
identation is a matter of taste, I guess. Why not :-)
> 3: I'd like to convert function comments to a common format.
> For example the javadoc style:
> * bar is a function
> * @param foo is a foo arg
> * @returns some value
I'm glad enough if people (including me) write comments at all... Feel
free to transform them into a common format. It may encourage people
to use the same format.
> 4: I'd like to start using "track" rather than "song" whereever
> possible. I think this makes for sense.
I've been doing that every time I ran across "song" in displayed
text. So it would only be consistent to change the function names
too. Sounds good to me.