This doesn't affect the behavior of things, but I think it would be
a bit safer (and would clear up a few warnings) if the single newAst
function were replaced with 4 functions with only a single parameter,
the properly typed opval:
ast* newAst_OP(unsigned op);
It seems that every call to newAst passes a constant value to the
newAst function, so there is no real need for the type to be a variable.
This extra bit of type safety should do a better job of preventing
inappropriate casts. Forgive me for being pedantic, but having an alpha
has made me think of these things:-)
I'll go ahead and make the changes, but I won't commit it right away so
that you have a chance to tell me I'm an idiot.
Steve Williams "The woods are lovely, dark and deep.
steve@... But I have promises to keep,
steve@... and lines to code before I sleep,
http://www.picturel.com And lines to code before I sleep."