> > I propose the following :
> > "count" for the number of inserted elements (wrt Enum)
> > "allocated_size" (or something else) for the size of the underlying
> Why not cardinal and array_length?
> cardinal vs. count: we don't trigger an iterative algorithm; cardinal is
> more neutral
> array_length: hash tables are always supposed to be based on arrays,
let me dismiss "cardinal" : we have already List.length , Enum.count,
IO.available ... users might be confused if we had one more way of counting
: IMHO "count" and "length" are the only choices, but "length" is more
appropriate for flat data structures such as List or Arrays.
about "array_length" I'm not satisfied either with "allocated_size" nor
"array_length" since the last one is giving information on how hashtbl are
implemented, which is never a good idea in an abstract interface.