On Aug 21, 2006, at 8:35 PM, Christoph Zwerschke wrote:
> I think I'm now done with this round of bug fixing. Webware should now
> install and run with all Python versions from 2.0 to 2.5 as claimed by
> the Docs and the Property files (at least all the unit tests pass);
> I tested it on some more platforms.
> The 0.9.2 beta release will be available in one or two days. But I
> this should be the last release to support such old Python versions.
> What do you suggest as the minimum Python version required when Python
> 2.5 is available? I think requiring Python 2.3 would be fair. This
> allow removing a lot of backward compatibility hacks and more
> and modern coding.
> -- Christoph
I would put my two cents on version 2.3, but only because 2.4 does
not run on older OS's like Fedora Core 1 and 2.
That said, as long a Webware 0.9.2 is kept on the web site for
downloading, moving to python 2.4 and above may simplify future work.