(Both messages did get through, BTW.)
I find unified diffs (diff -u) are far easier to read.
On vil_jpeg_compressor, you set quality as a static int, implying then
that all the writers will use the same quality. I think it's better for
that variable not be static, and allow each writer to set its quality
independently. The default can be set to 75 (as you have it) in the
On j2k: I think the new signature is quite likely to conflict with
existing uses, since the factors are likely to be integers in many
applications, and folks will likely have written "2" instead of "2.0".
Unfortunately, this would cause a "silent" error, and so I think we
should avoid it. Maybe rename the new function to something else? I
can't think of a good name. Maybe something along the lines of
On vgl: good with me. Avoiding stack overflows seems to be a good idea.
:-) (I assume the tests still pass.)