On Tue, Sep 07, 2010 at 01:34:18AM +0900, Mathieu Blondel wrote:
> On Fri, Sep 3, 2010 at 7:01 PM, Vincent Michel <vm.michel@...> wrote:
> > - anything you can think of.
> During the coding sprint, one thing that would be nice to standardize
> for the generative models (hmm, gmm, lda, naive_bayes, ...) is a
> sampling method for generating a data matrix from the model (thus the
> model must be fitted or the parameters must be set by hand by the user
> first). This can be useful for program examples and unit testing. In
> the HMM and GMM modules, there's already such a method and it is
> called "rvs". To continue with the simple names such as "fit",
> "transform" and "score", simply "sample" would be nice.
"rvs" was inspired by the scipy.stats interface (gmm.score also used
to be called gmm.pdf). "sample" is definitely more consistent with
the other naming conventions.
That said, I'm not really sure what it means to sample from a
*transform* like LDA.