Someone (Nathan?) asked on #lisp about the :WRITER-VOP stuff, that is:
:ACCESSOR-NAME is old and names the symbol for a reader function for
which there is a VOP translation, and a SETF expansion. :WRITER-VOP
names the _VOP_ which correspond to the writer function translation.
Unfortunately, the functions are called %RAW-INSTANCE-FOO and the vops
are named RAW-INSTANCE-FOO.
I would be inclined to rename the vops %RAW-INSTANCE-FOO as well, and
rename :ACCESSOR-NAME to :READER-NAME and :WRITER-VOP to :WRITER-NAME
-- but decided against that in the patch itself, since it would have
touched all the backends. I think that is best left as a post-merge
cleanup for clarity.
Apropos: is there a reason for this not-unique-to-raw-accessors
convention of calling a function with a translation vop %FOO, and the
vop itself FOO? In most cases when it has mattered it to me, it has
mostly been a source of bugs (wrong symbol, wrong package, etc.)