On Sun, Oct 28, 2012 at 6:56 PM, Roy Stogner <roystgnr@...:
> You could probably leave it to David or one of the other rbOOmit
> people to fix up the reduced_basis internal code. In any case it's
> not urgent that library code be *using* the accessors before the next
> release, it's just critical that the accessors be available (for
> forwards compatibility) and important that the examples be using them
> (to encourage new users to do so too).
OK, I'll let David handle the rbOOmit parts. And I'll focus on the examples
1. The use of "get_" in the names
> Ugly, but hard to avoid, since we can't just use the original names
> alone for the accessors without breaking backwards compatibility.
Yeah, this was the reason I used "get_" in the first place. I'll leave it
> 2. overloading get_elem_residual (for example) instead of doing
> I'd rather have get_elem_subresidual etc. (less overloading sometimes
> means easier debugging and/or more ease adding optional default
> arguments if we need to later) but I'd defer to your preference.
I feel obligated to go with your preference since you wrote the original
code, but just to mention why I prefer the overload - when I first started,
I found residual vs. subresidual a bit confusing (because was there
something else special about the subresidual besides it just being specific
to the variable? Had to look at the code to find out; obviously I know the
answer now). But I could see an argument that such confusion would be
cleared up by documentation (which will be added before the patch goes in!).
John, David, Vikram, others: any opinions? Not trying to make a mountain
out of mole hills, but figure since we'll be breaking compatibility, here's
a chance to try and make API as clear as possible.