-----BEGIN PGP SIGNED MESSAGE-----
On 02/01/2013 01:51 AM, Artem Bityutskiy wrote:
> On Tue, 2013-01-29 at 10:23 -0600, Dave Kleikamp wrote:
>> - .aio_read = generic_file_aio_read, - .aio_write =
>> generic_file_aio_write, + .read_iter =
>> generic_file_read_iter, + .write_iter =
> The new names a lot less self-documenting than the old ones - I
> read them as "read iteration", because "iter" is often used for
> "iteration", and this gives me no clue that they are related to
Zach Brown originally came up with these (or at least he's the one who
did the majority of the initial work with this patchset) and I can't
speak for him, but I'm not sure if I could come up with a better name.
(Maybe aio_read_iter/aio_write_iter?) These operations are
differentiated from aio_read/write because they take the iov_iter
argument rather than an iovec, so "iter" does seem appropriate.
> I apologize if this was already discussed, but why did you choose
It hasn't been discussed, but nobody has said anything about the names
until now. I hesitate to change the proposed names now unless there's
some kind of consensus to do so.
If others chime in and want me to change these to aio_read_iter and
aio_write_iter or something else, I'll consider it.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.19 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/
-----END PGP SIGNATURE-----