On Saturday 21 March 2009 10:52:36 James Harper wrote:
> > On Saturday 21 March 2009 10:37:25 James Harper wrote:
> > > Just a small thing... "Full Pool" and "Full Backup Pool" accomplish
> > the
> > > same things but "Full Pool" is only valid in a Schedule resource and
> > > "Full Backup Pool" is only valid in a Job resource. Could they be
> > made
> > > to be synonyms for each other without too much fuss?
> > Can you be more specific where "Full Pool" and "Full Backup Pool" are
> > used?
> "Full Pool" is used to override the Pool for a given Schedule
> definition, but only when the backup is a Full one (either because it
> was specified as Full or it has been upgraded to Full)
> "Full Backup Pool" does exactly the same thing but in a Job definition,
> as opposed to a Schedule definition.
OK, I see what you are talking about.
> They both serve the same sort of function and I thought it was a bit
> silly that the syntax is different, or maybe there is a reason for it
> (parser limitation maybe?)
Yes, it is not very good. It has nothing to do with a parser limitation; it
was just that whoever (probably me) programmed it didn't take care to see
what the previous definition was and use the same words.
1. I can easily add synonyms in the Schedule resource, so we could add
FullBackupPool, DifferentialBackupPool, and IncrementalBackupPool.
Unfortunately, these names are a bit long.
2. On the other hand, though it is easy to add synonyms in the Job resource,
it creates problems with JobDefs if you don't use the same synonyms in both
the JobDefs and the Job. So I would hesitate to add FullPool,
DifferentialPool, and IncrementalPool to the Job resource.
I have no problem doing #1 above, and eventhough I like the shorter names,
adding them as described in #2 poses a problem.
Before making any change, I would like to get your reaction and that of other
people on the lists ...