1. Summary
  2. Files
  3. Support
  4. Report Spam
  5. Create account
  6. Log in

Ticket #76 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

Locked wheels even when ABS on

Reported by: madbad Owned by: andrewsumner
Priority: major Milestone: to be defined
Component: Robots Version: 1.4.0 beta 1
Keywords: ABS Cc:

Description

Happens very often, nearly on every car.
In Pro mode. Not tested in lower skill modes.

Change History

Changed 4 years ago by harunasan

  • owner changed from somebody to andrewsumner
  • status changed from new to assigned

Since Andrew is the one who wrote the new human "robot", it'd probably be a good idea to let him do the work.

Changed 4 years ago by kakukri

Copied from #206:
This raised a light bulb in my brain.... indeed ABS is controlled within 'human.cpp' (starting line 941), which reduces braking if _averaged_ slip is above a threshold.

The problem is that braking command is split unevenly between front/back wheels, so therefore you will always end up with the front (or back, depending on split) wheels more likely to lock.

This is probably a separate bug, but shouldn't the ABS system consider each wheel independently and release the pressure only on the slipping wheel(s)?

Simon.

Changed 4 years ago by kakukri

I think currently there is no interface for human.cpp to interact with brake pressures of the wheels, it can only decrease the brake command. So for now I suggest to use the maximum of the 4 slip instead of the average.

On the long run, we might implement either an interface for controlling separately the pressures of wheels, or move the ABS inside simu, then it has access for it. I would prefer the second option, as the ABS is actually part of the car, and robots/ humans should only play with the brake pedal.

Changed 3 years ago by andrewsumner

  • status changed from assigned to closed
  • resolution set to fixed

Fixed unless someone tells me otherwise :)

Lowering brake pressures on most of our cars will also help a lot.

Changed 3 years ago by kakukri

Just did a quick test, and works pretty well now. Even 36GP cars are now drivable with keyboard/mouse combo. Nice :).

Note: See TracTickets for help on using tickets.