1. Summary
  2. Files
  3. Support
  4. Report Spam
  5. Create account
  6. Log in

Ticket #701 (closed: fixed)

Opened 5 years ago

Last modified 5 years ago

git hook email sending revisited

Reported by: pekberg Owned by: nhruby
Keywords: SOG Cc:
Private: no

Description

Originally ticketed at: https://sourceforge.net/tracker/?func=detail&aid=2685702&group_id=1&atid=200001

Hi!

I have a problem with commit notifications in a git repo (ggivnc). I
thought I had it figured out, but as it happens I didn't...

My git hooks/update attempts to send two emails, one to an ordinary commit
mailing list, the other to cia@cia.vc.

The mail to the commit ML works just fine and if I replicate the below SMTP
actions on the SMTP server of my ISP the notification to cia gets through,
so I don't think it's an error on my part (famous last words).

I hope the two SMTP sessions below make sense. The first one worked, the
second not (at least no evidence of cia noticing the mail).

[<-] 220 cxgxhf1.ch3.sourceforge.com ESMTP Exim 4.69 Thu, 12 Mar 2009
22:23:13 +0000
[->] HELO cxgxhf1.ch3.sourceforge.com
[<-] 250 cxgxhf1.ch3.sourceforge.com Hello localhost [127.0.0.1]
[->] MAIL FROM:<pekberg@users.sourceforge.net>
[<-] 250 OK
[->] RCPT TO:<ggivnc-commit@lists.sourceforge.net>
[<-] 250 Accepted
[->] DATA
[<-] 354 Enter message, ending with "." on a line by itself
[->] Received: by cxgxhf1.ch3.sourceforge.com (sSMTP sendmail emulation);
Thu, 12 Mar 2009 22:23:13 +0000
[->] Date: Thu, 12 Mar 2009 22:23:13 +0000
[->] From: pekberg@users.sourceforge.net
[->] To: ggivnc-commit@lists.sourceforge.net
[->] Content-type: text/plain; charset=UTF-8
[->] Subject: Peter Rosin : Add missing line continuation.
[->] 
[->] Module: ggivnc
[->] Branch: master
[->] Commit: a7f618261be8c3e32fce3d081056c41ecd9c88e2
[->] URL: 
http://ggivnc.git.sourceforge.net/git/gitweb.cgi?p=ggivnc;a=commit;h=a7f618
261be8c3e32fce3d081056c41ecd9c88e2
[->] 
[->] Author: Peter Rosin <peda@lysator.liu.se>
[->] Date: Thu Mar 12 22:51:04 2009 +0100
[->] 
[->] Add missing line continuation.
[->] 
[->] ---
[->] 
[->] configure.ac | 2 +-
[->] 1 files changed, 1 insertions(+), 1 deletions(-)
[->] 
[->] diff --git a/configure.ac b/configure.ac
[->] index 546a565..e0ac3e0 100644
[->] --- a/configure.ac
[->] +++ b/configure.ac
[->] @@ -313,7 +313,7 @@ AC_CHECK_FUNCS(vsnprintf)
[->] if test "x$ac_cv_func_vsnprintf" != xyes; then
[->] AC_CHECK_FUNCS(_vsnprintf)
[->] if test "x$ac_cv_func__vsnprintf" != xyes; then
[->] - if test "x$ac_cv_func_snprintf" = xyes -o
[->] + if test "x$ac_cv_func_snprintf" = xyes -o \
[->] "x$ac_cv_func__snprintf" = xyes; then
[->] AC_LIBOBJ([snprintf])
[->] fi
[->] 
[->] .
[<-] 250 OK id=1LhtJ3-0003ta-Nf
[->] QUIT
[<-] 221 cxgxhf1.ch3.sourceforge.com closing connection



[<-] 220 cxgxhf1.ch3.sourceforge.com ESMTP Exim 4.69 Thu, 12 Mar 2009
22:23:14 +0000
[->] HELO cxgxhf1.ch3.sourceforge.com
[<-] 250 cxgxhf1.ch3.sourceforge.com Hello localhost [127.0.0.1]
[->] MAIL FROM:<pekberg@users.sourceforge.net>
[<-] 250 OK
[->] RCPT TO:<cia@cia.vc>
[<-] 250 Accepted
[->] DATA
[<-] 354 Enter message, ending with "." on a line by itself
[->] Received: by cxgxhf1.ch3.sourceforge.com (sSMTP sendmail emulation);
Thu, 12 Mar 2009 22:23:14 +0000
[->] Date: Thu, 12 Mar 2009 22:23:14 +0000
[->] From: pekberg@users.sourceforge.net
[->] To: cia@cia.vc
[->] Content-type: text/xml
[->] Subject: DeliverXML
[->] 
[->] <message>
[->] <generator>
[->] <name>git-notify script for CIA</name>
[->] </generator>
[->] <source>
[->] <project>ggivnc</project>
[->] <module>ggivnc</module>
[->] <branch>master</branch>
[->] </source>
[->] <body>
[->] <commit>
[->] <revision>a7f618261b</revision>
[->] <author>Peter Rosin &lt;peda@lysator.liu.se&gt;</author>
[->] <log>Add missing line continuation.</log>
[->] <files>
[->] <file action="modify">configure.ac</file>
[->] </files>
[->] 
<url>http://ggivnc.git.sourceforge.net/git/gitweb.cgi?p=ggivnc;a=commit;h=a
7f618261be8c3e32fce3d081056c41ecd9c88e2</url>
[->] </commit>
[->] </body>
[->] <timestamp>1236894664</timestamp>
[->] </message>
[->] .
[<-] 250 OK id=1LhtJ4-0003tj-PH
[->] QUIT
[<-] 221 cxgxhf1.ch3.sourceforge.com closing connection
All pending mails to cia@cia.vc have now timed out after 96 hours. The
messages were:

Received: from localhost ([127.0.0.1] helo=fxgxhf1.ch3.sourceforge.com)
by fxgxhf1.ch3.sourceforge.com with smtp (Exim 4.69)
(envelope-from <pekberg@users.sourceforge.net>)
id 1LhmsG-0007mn-0S
for cia@cia.vc; Thu, 12 Mar 2009 15:31:09 +0000

Received: from localhost ([127.0.0.1] helo=cxgxhf1.ch3.sourceforge.com)
by cxgxhf1.ch3.sourceforge.com with smtp (Exim 4.69)
(envelope-from <pekberg@users.sourceforge.net>)
id 1Lhr5z-0005J0-AR
for cia@cia.vc; Thu, 12 Mar 2009 20:01:36 +0000

Received: from localhost ([127.0.0.1] helo=cxgxhf1.ch3.sourceforge.com)
by cxgxhf1.ch3.sourceforge.com with smtp (Exim 4.69)
(envelope-from <pekberg@users.sourceforge.net>)
id 1LhrA8-0005Uj-H2
for cia@cia.vc; Thu, 12 Mar 2009 20:05:53 +0000

Received: from localhost ([127.0.0.1] helo=cxgxhf1.ch3.sourceforge.com)
by cxgxhf1.ch3.sourceforge.com with smtp (Exim 4.69)
(envelope-from <pekberg@users.sourceforge.net>)
id 1LhtJ4-0003tj-PH
for cia@cia.vc; Thu, 12 Mar 2009 22:23:15 +0000

Please do not dig out these messages to send them to cia, I have already
sent them by other means so any such action on your part would cause
duplicates. But I would still very much like to know what I should do the
get emails delivered to cia. Should I contact cia, or is the problem at
SF?

One possible explanation would be if cia has some spam filter that
requires the SMTP client to retry after some time period and that SF is
missing the deadline or something. But I'm no SMTP expert and is out on a
pretty thin limb guessing the cause...

Cheers,
Peter
I just noticed some messages in my junk mail folder:

(while this is not in response to the reported attempted mailing, it is
from another commit. So, it appears that the mails are stuck somewhere.)


Subject: Warning: message 1LhmsG-0007mn-0S delayed 24 hours

This message was created automatically by mail delivery software.
A message that you sent has not yet been delivered to one or more of its
recipients after more than 24 hours on the queue on
fxgxhf1.ch3.sourceforge.com.

The message identifier is: 1LhmsG-0007mn-0S
The date of the message is: Thu, 12 Mar 2009 15:31:08 +0000
The subject of the message is: DeliverXML

The address to which the message has not yet been delivered is:

cia@cia.vc

No action is required on your part. Delivery attempts will continue for
some time, and this warning may be repeated at intervals if the message
remains undelivered. Eventually the mail delivery software will give up,
and when that happens, the message will be returned to you.




I have also received similar messages about message id 1LhKoe-0004nz-PT,
but that one was sent to cia@cia.navi.cx, and I'm not sure if that is still
supposed to work.

Cheers,
Peter

Change History

Changed 5 years ago by dricci

  • keywords ENGR added

Changed 5 years ago by nhruby

  • keywords SOG added; ENGR removed
  • status changed from new to assigned

Changed 5 years ago by nhruby

  • status changed from assigned to closed
  • resolution set to fixed

Hi Peter,

Sorry for the delay in getting this resolved, but it should be functioning correctly now. Thanks very much for bringing this to our attention!

nathan hruby
System Programmer Analyst II
Service Operations Group - SourceForge.net

Note: See TracTickets for help on using tickets.