1. Summary
  2. Files
  3. Support
  4. Report Spam
  5. Create account
  6. Log in

Ticket #26892 (closed: fixed)

Opened 21 months ago

Last modified 21 months ago

Unable to push git repository

Reported by: kerneis Owned by:
Keywords: Cc:
Private: no

Description

Hello,

When I try to push a local git repository to an empty remote repository, I get the following error:

$ git push --verbose sourceforge develop 
Pushing to ssh://kerneis,cil@cil.git.sourceforge.net/gitroot/cil/cil
Password: 
Counting objects: 7, done.
Delta compression using up to 2 threads.
Compressing objects: 100% (4/4), done.
Writing objects: 100% (4/4), 406 bytes, done.
Total 4 (delta 3), reused 0 (delta 0)
error: insufficient permission for adding an object to repository database ./objects

fatal: failed to write object
error: unpack failed: unpack-objects abnormal exit
To ssh://kerneis,cil@cil.git.sourceforge.net/gitroot/cil/cil
 ! [remote rejected] develop -> develop (n/a (unpacker error))
error: failed to push some refs to 'ssh://kerneis,cil@cil.git.sourceforge.net/gitroot/cil/cil'

This is similar to issues #4956 and #7169 but I've tried the proposed workaround (adding project name to git remote, clearing and adding again permissions in web interface) and they do not work for me.

Change History

Changed 21 months ago by kerneis

Hmm, sorry cut-and-paste issue, it not an empty repository, but a repository that used to work very well until two days ago.

Changed 21 months ago by kerneis

Duplicate of #26891 obviously.

Changed 21 months ago by rbowen

  • status changed from new to closed
  • resolution set to fixed

This issue affected a number of projects, and was resolved this morning. Thanks for bringing it to our attention.

Note: See TracTickets for help on using tickets.