1. Summary
  2. Files
  3. Support
  4. Report Spam
  5. Create account
  6. Log in

Ticket #26540 (closed: fixed)

Opened 22 months ago

Last modified 22 months ago

Tracker - strange behaviour after project upgrade

Reported by: hobiwan Owned by: ctsai
Keywords: PEND Cc:
Private: no

Description

I upgraded my project HoDoKu and had strange behaviour in "Bugs and feature Requests". For item 219 (https://sourceforge.net/p/hodoku/bugs-and-feature-requests/219/) the discussion was missing, although I had already posted a reply (reply1) and gotten an answer (answer1).

I assumed that those posts were lost, so I posted a new reply (reply2). After clicking on "Post" the new reply2 disappeared and the old posts (reply1 and answer1) were shown.

Now I wrote a reply (reply3) to the old posts. After pressing "Post" the old posts disappeared again and reply2 was shown. The new post (reply3) was absent again.

Attachments

tracker_bug_20120709.PNG (68.8 KB) - added by hobiwan 22 months ago.
scrtrack02.JPG (68.8 KB) - added by hobiwan 22 months ago.
scrtrack03.JPG (72.3 KB) - added by hobiwan 22 months ago.
scrtrack04.JPG (94.0 KB) - added by hobiwan 22 months ago.

Change History

Changed 22 months ago by hobiwan

Just posted a reply to another topic (http://sourceforge.net/apps/trac/sourceforge/ticket/26540>) and now 5 pages of comments are gone!

Monitoring doesnt work as it used to either: I used to get emails for all changes in the tracker, now I dont get anything!

If I click on the "Subscribe to this ticket" link, nothing happens.

Changed 22 months ago by hobiwan

Further testing: I added another post to the second thread and now all the old posts have reappeared (but the latest is missing).

Changed 22 months ago by hobiwan

Changed 22 months ago by hobiwan

Statistics dont work correctly either: As you can see in the screenshot, there are 10 open tracker items, but 12 is shown under "Open".

Closing tickets has the same behaviour as above: If you close a ticket, it is displayed by a search for open tickerts, but marked as closed. If you close another one, the first one disappears from the list.

Changed 22 months ago by ctsai

  • keywords ENGR NF-4515 added
  • owner set to ctsai
  • status changed from new to assigned

I'm escalating the issue with the posts appearing/disappearing to our engineering team here: https://sourceforge.net/p/allura/tickets/4515/

As for the subscriptions, what do you see on your subscriptions page? https://sourceforge.net/prefs/auth/

And for the search counts item, note that the updates to the saved searches are processed on a slight delay, so recent changes may not be visible right away, but should correct shortly. I just checked now and I'm seeing a correct count of 11 open tickets (ie., the number in the sidebar matches the count of visible tickets).

Regards,
Chris Tsai, SourceForge.net Support

Changed 22 months ago by ctsai

  • keywords PEND added; ENGR NF-4515 removed

Hello,

The post appearing/disappearing issue should be fixed now. Please confirm.

Regards,
Chris Tsai, SourceForge.net Support

Changed 22 months ago by hobiwan

Changed 22 months ago by hobiwan

Post in tracker work fine now, thanks for that, but monitoring is still broken:

When I select an item in the tracker (e.g. https://sourceforge.net/p/hodoku/bugs-and-feature-requests/204/ and click on the small envelope (which points to https://sourceforge.net/p/hodoku/bugs-and-feature-requests/204/subscribe?subscribe=True) the browser handles the request, but nothing changes in my account (https://sourceforge.net/account/monitoring - see screenshot scrtrack02.jpg).

When going to the top of the tracker (https://sourceforge.net/p/hodoku/bugs-and-feature-requests/) the envelope has a blue border and the URL its pointing to is https://sourceforge.net/p/hodoku/bugs-and-feature-requests/subscribe?unsubscribe=True, which means I am monitoring the tracker. But if I post a new item or delete it again, no email is sent.

In the monitoring list I have multiple entries for "Help" and "Open Discussion", but posts there dont trigger emails as well.

Changed 22 months ago by hobiwan

Incidentally I do get notification emails for changes here, so the email system itself is working.

Changed 22 months ago by ctsai

The account monitoring page is only for the classic system. For upgraded projects, there's a new subscription page as I mentioned before: https://sourceforge.net/prefs/auth/

What do you see there?

Thanks!
Chris Tsai, SourceForge.net Support

Changed 22 months ago by hobiwan

Changed 22 months ago by hobiwan

404 (see screenshot) - thats why I looked at the monitoring page.

Changed 22 months ago by ctsai

Oops, I flipped that around, should be https://sourceforge.net/auth/prefs/

Changed 22 months ago by hobiwan

Changed 22 months ago by hobiwan

Suscribed to everything as far as I can see.

Changed 22 months ago by ctsai

  • keywords ENGR NF-4532 added; PEND removed

I'm seeing similar reports from other users with recently migrated projects. I've escalated this to our engineering team to investigate as a bug: https://sourceforge.net/p/allura/tickets/4532/

Regards,
Chris Tsai, SourceForge.net Support

Changed 22 months ago by ctsai

  • keywords PEND added; ENGR NF-4532 removed

Okay, so it looks like there was a bug that the team had already noticed and created a fix for, and they just needed to run it for your project. Essentially, we turn off notifications during the migration process (so you don't get an email for each ticket, etc. migrated), but we didn't turn it back on after. The script to fix this has been run and notifications should be working for your project now.

Please confirm.

Thanks!
Chris Tsai, SourceForge.net Support

Changed 22 months ago by hobiwan

Thanks for your efforts!

I do get emails now if I post in a thread, I didnt get one when I opened a new tracker item.

Changed 22 months ago by ctsai

  • keywords ENGR NF-4532 added; PEND removed

Based on your response and some of my own testing, I've reopened the following ticket for further evaluation: https://sourceforge.net/p/allura/tickets/4532/

Regards,
Chris Tsai, SourceForge.net Support

Changed 22 months ago by ctsai

  • keywords PEND added; ENGR NF-4532 removed

Hello again,

So, it looks like when we were both testing later, the team was performing a code push, which was causing various items to be delayed for a time. The test messages ended up being processed and delivered later for me. How about you? Please advise.

Thanks,
Chris Tsai, SourceForge.net Support

Changed 22 months ago by hobiwan

I just created a new tracker item and did receive a notification email - seems to work now.

Thanks for your effort!

Changed 22 months ago by ctsai

  • status changed from assigned to closed
  • resolution set to fixed

Great, thanks.

Regards,
Chris Tsai, SourceForge.net Support

Note: See TracTickets for help on using tickets.